aboutsummaryrefslogtreecommitdiff
path: root/drivers/base/ump/src/imports/ion/Makefile
diff options
context:
space:
mode:
authorArvind Chauhan <arvind.chauhan@arm.com>2017-11-07 11:32:48 +0530
committerArvind Chauhan <arvind.chauhan@arm.com>2017-11-07 11:32:48 +0530
commitda4440b88e736d43ec574438a09cd19f6c18ee02 (patch)
tree073a57cd16042e6e66e98e0632fdda2f5c1fd8d3 /drivers/base/ump/src/imports/ion/Makefile
parent5e069b9771bda2b14a24c7c49bd1cbde8ef3a695 (diff)
parentcf9f7e85800ef8e00cc98db2e6730ed9e6c3dbaa (diff)
Merge branch '4.9-armlt-mali' into 4.9-armltack-4.9-armlt-20171114lsk-4.9-armlt
Diffstat (limited to 'drivers/base/ump/src/imports/ion/Makefile')
-rw-r--r--drivers/base/ump/src/imports/ion/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/drivers/base/ump/src/imports/ion/Makefile b/drivers/base/ump/src/imports/ion/Makefile
new file mode 100644
index 000000000000..ef74b273f7ad
--- /dev/null
+++ b/drivers/base/ump/src/imports/ion/Makefile
@@ -0,0 +1,53 @@
+#
+# (C) COPYRIGHT 2011, 2013 ARM Limited. All rights reserved.
+#
+# This program is free software and is provided to you under the terms of the
+# GNU General Public License version 2 as published by the Free Software
+# Foundation, and any use by you of this program is subject to the terms
+# of such GNU licence.
+#
+# A copy of the licence is included with the program, and can also be obtained
+# from Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301, USA.
+#
+#
+
+
+
+
+# default to building for the host
+ARCH ?= $(shell uname -m)
+
+# linux build system integration
+
+ifneq ($(KERNELRELEASE),)
+# Inside the kernel build system
+
+EXTRA_CFLAGS += -I$(KBUILD_EXTMOD) -I$(KBUILD_EXTMOD)/../../../../..
+KBUILD_EXTRA_SYMBOLS += "$(KBUILD_EXTMOD)/../../Module.symvers"
+
+SRC += ump_kernel_import_ion.c
+
+MODULE:=ump_ion_import.ko
+
+obj-m := $(MODULE:.ko=.o)
+$(MODULE:.ko=-y) := $(SRC:.c=.o)
+$(MODULE:.ko=-objs) := $(SRC:.c=.o)
+
+else
+# Outside the kernel build system
+#
+#
+
+ifeq ($(KDIR),)
+$(error Must specify KDIR to point to the kernel to target))
+endif
+
+all:
+ $(MAKE) ARCH=$(ARCH) -C $(KDIR) M=$(CURDIR)
+
+clean:
+ $(MAKE) ARCH=$(ARCH) -C $(KDIR) M=$(CURDIR) clean
+
+endif
+