aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2012-09-25 00:29:45 +0200
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2012-09-25 00:29:45 +0200
commit879d9abeb78a971c1d5611320244201c1b3c48e0 (patch)
tree9fc37d3017b947d2b269b2e90011e1041d1475e4
parent8a55ca25e1e751b026ca2ae5d42c10f26d6b3ef5 (diff)
Imported Upstream version 1.0.0upstream/1.0.0
-rw-r--r--Makefile.in25
-rw-r--r--NEWS38
-rw-r--r--common/release.mak25
-rwxr-xr-xconfigure30
-rw-r--r--configure.ac4
-rw-r--r--gst-libav.doap10
-rw-r--r--gst-libav.spec2
-rw-r--r--tests/check/elements/avdec_adpcm.c2
-rw-r--r--tests/check/elements/avdemux_ape.c2
9 files changed, 71 insertions, 67 deletions
diff --git a/Makefile.in b/Makefile.in
index d54b8e9..2093c37 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -983,11 +983,24 @@ check-nonportable-print-format:
dist-hook: check-exports win32-check-crlf
release: dist
- $(MAKE) $(PACKAGE)-$(VERSION).tar.xz.md5
+ @$(MAKE) $(PACKAGE)-$(VERSION).tar.xz.sha256sum
+ @echo
+ @echo "================================================================================================="
+ @echo "http://gstreamer.freedesktop.org/src/$(PACKAGE)/$(PACKAGE)-$(VERSION).tar.xz"
+ @cat $(PACKAGE)-$(VERSION).tar.xz.sha256sum
+ @echo "================================================================================================="
+ @if [ -d ~/releases/ ]; then \
+ cp -v $(PACKAGE)-$(VERSION).tar.xz ~/releases/; \
+ fi
+ @if [ -d ../www/data/src ]; then \
+ mv -v $(PACKAGE)-$(VERSION).tar.xz ../www/data/src/$(PACKAGE)/ ; \
+ mv -v $(PACKAGE)-$(VERSION).tar.xz.sha256sum ../www/data/src/$(PACKAGE)/ ; \
+ fi
+ @echo "================================================================================================="
-# generate md5 sum files
-%.md5: %
- md5sum $< > $@
+# generate sha256 sum files
+%.sha256sum: %
+ @sha256sum $< > $@
# check that no marshal or enumtypes files are included
# this in turn ensures that distcheck fails for missing .list files which is currently
@@ -995,8 +1008,8 @@ release: dist
distcheck-hook:
@test "x" = "x`find $(distdir) -name \*-enumtypes.[ch] | grep -v win32`" && \
test "x" = "x`find $(distdir) -name \*-marshal.[ch]`" || \
- ( $(ECHO) "*** Leftover enumtypes or marshal files in the tarball." && \
- $(ECHO) "*** Make sure the following files are not disted:" && \
+ ( echo "*** Leftover enumtypes or marshal files in the tarball." && \
+ echo "*** Make sure the following files are not disted:" && \
find $(distdir) -name \*-enumtypes.[ch] | grep -v win32 && \
find $(distdir) -name \*-marshal.[ch] && \
false )
diff --git a/NEWS b/NEWS
index f5aa809..304112b 100644
--- a/NEWS
+++ b/NEWS
@@ -1,38 +1,6 @@
-This is GStreamer libav Plug-ins 0.11.92 "Wish You Were Here"
+This is GStreamer Libav Plugins 1.0.0
-New in 0.11.92:
+New features in 1.0.0:
* Parallel installability with 0.10.x series
- * API cleanup and minor API improvements
- * Lots of bugfixes, cleanup and other improvements
-
-New in 0.11.91:
-
- * Lots of bugfixes and other improvements
-
-New in 0.11.90:
-
- * Lots of bugfixes, cleanup and other improvements
- * Renamed from gst-ffmpeg to libav, also all element factory names now start with an 'av' prefix instead of 'ff'
- * Handle difference between DTS/PTS properly
-
-New in 0.11.2:
-
- * Many cleanups
- * Ported to new 0.11 core API changes
- * Disable ffmpeg multithreading
- * Add support for the VOC format
- * Improve memory allocation
- * Optimize for 0-padded input buffers
-
-Bugs fixed in this release
-
- * 664687 : CPU count detection fails on OS X
-
-New in 0.11.1:
-
- * Parallel installability with 0.10.x series
- * Threadsafe design and API
- * Many cleanups
- * Ported to new 0.11 core API changes
-
+ * See release notes for more details
diff --git a/common/release.mak b/common/release.mak
index 7fbf4ca..715657b 100644
--- a/common/release.mak
+++ b/common/release.mak
@@ -2,11 +2,24 @@
# include $(top_srcdir)/common/release.mak
release: dist
- $(MAKE) $(PACKAGE)-$(VERSION).tar.xz.md5
+ @$(MAKE) $(PACKAGE)-$(VERSION).tar.xz.sha256sum
+ @echo
+ @echo "================================================================================================="
+ @echo "http://gstreamer.freedesktop.org/src/$(PACKAGE)/$(PACKAGE)-$(VERSION).tar.xz"
+ @cat $(PACKAGE)-$(VERSION).tar.xz.sha256sum
+ @echo "================================================================================================="
+ @if [ -d ~/releases/ ]; then \
+ cp -v $(PACKAGE)-$(VERSION).tar.xz ~/releases/; \
+ fi
+ @if [ -d ../www/data/src ]; then \
+ mv -v $(PACKAGE)-$(VERSION).tar.xz ../www/data/src/$(PACKAGE)/ ; \
+ mv -v $(PACKAGE)-$(VERSION).tar.xz.sha256sum ../www/data/src/$(PACKAGE)/ ; \
+ fi
+ @echo "================================================================================================="
-# generate md5 sum files
-%.md5: %
- md5sum $< > $@
+# generate sha256 sum files
+%.sha256sum: %
+ @sha256sum $< > $@
# check that no marshal or enumtypes files are included
# this in turn ensures that distcheck fails for missing .list files which is currently
@@ -14,8 +27,8 @@ release: dist
distcheck-hook:
@test "x" = "x`find $(distdir) -name \*-enumtypes.[ch] | grep -v win32`" && \
test "x" = "x`find $(distdir) -name \*-marshal.[ch]`" || \
- ( $(ECHO) "*** Leftover enumtypes or marshal files in the tarball." && \
- $(ECHO) "*** Make sure the following files are not disted:" && \
+ ( echo "*** Leftover enumtypes or marshal files in the tarball." && \
+ echo "*** Make sure the following files are not disted:" && \
find $(distdir) -name \*-enumtypes.[ch] | grep -v win32 && \
find $(distdir) -name \*-marshal.[ch] && \
false )
diff --git a/configure b/configure
index 0e1071d..850c156 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for GStreamer libav 0.11.99.
+# Generated by GNU Autoconf 2.69 for GStreamer libav 1.0.0.
#
# Report bugs to <http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer>.
#
@@ -591,8 +591,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='GStreamer libav'
PACKAGE_TARNAME='gst-libav'
-PACKAGE_VERSION='0.11.99'
-PACKAGE_STRING='GStreamer libav 0.11.99'
+PACKAGE_VERSION='1.0.0'
+PACKAGE_STRING='GStreamer libav 1.0.0'
PACKAGE_BUGREPORT='http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer'
PACKAGE_URL=''
@@ -1505,7 +1505,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures GStreamer libav 0.11.99 to adapt to many kinds of systems.
+\`configure' configures GStreamer libav 1.0.0 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1576,7 +1576,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of GStreamer libav 0.11.99:";;
+ short | recursive ) echo "Configuration of GStreamer libav 1.0.0:";;
esac
cat <<\_ACEOF
@@ -1738,7 +1738,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-GStreamer libav configure 0.11.99
+GStreamer libav configure 1.0.0
generated by GNU Autoconf 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
@@ -2153,7 +2153,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by GStreamer libav $as_me 0.11.99, which was
+It was created by GStreamer libav $as_me 1.0.0, which was
generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
@@ -3083,7 +3083,7 @@ fi
# Define the identity of the package.
PACKAGE='gst-libav'
- VERSION='0.11.99'
+ VERSION='1.0.0'
cat >>confdefs.h <<_ACEOF
@@ -3206,9 +3206,9 @@ $as_echo "$am_cv_prog_tar_ustar" >&6; }
- PACKAGE_VERSION_MAJOR=$(echo 0.11.99 | cut -d'.' -f1)
- PACKAGE_VERSION_MINOR=$(echo 0.11.99 | cut -d'.' -f2)
- PACKAGE_VERSION_MICRO=$(echo 0.11.99 | cut -d'.' -f3)
+ PACKAGE_VERSION_MAJOR=$(echo 1.0.0 | cut -d'.' -f1)
+ PACKAGE_VERSION_MINOR=$(echo 1.0.0 | cut -d'.' -f2)
+ PACKAGE_VERSION_MICRO=$(echo 1.0.0 | cut -d'.' -f3)
@@ -3219,7 +3219,7 @@ $as_echo "$am_cv_prog_tar_ustar" >&6; }
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking nano version" >&5
$as_echo_n "checking nano version... " >&6; }
- NANO=$(echo 0.11.99 | cut -d'.' -f4)
+ NANO=$(echo 1.0.0 | cut -d'.' -f4)
if test x"$NANO" = x || test "x$NANO" = "x0" ; then
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: 0 (release)" >&5
@@ -12126,7 +12126,7 @@ CC="$lt_save_CC"
-GST_REQ=0.11.99
+GST_REQ=1.0.0
ORC_REQ=0.4.16
@@ -17802,7 +17802,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by GStreamer libav $as_me 0.11.99, which was
+This file was extended by GStreamer libav $as_me 1.0.0, which was
generated by GNU Autoconf 2.69. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -17868,7 +17868,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-GStreamer libav config.status 0.11.99
+GStreamer libav config.status 1.0.0
configured by $0, generated by GNU Autoconf 2.69,
with options \\"\$ac_cs_config\\"
diff --git a/configure.ac b/configure.ac
index a49edae..87d63d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@ AC_PREREQ(2.62)
dnl initialize autoconf
dnl when going to/from release please set the nano (fourth number) right !
dnl releases only do Wall, cvs and prerelease does Werror too
-AC_INIT(GStreamer libav, 0.11.99,
+AC_INIT(GStreamer libav, 1.0.0,
http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer,
gst-libav)
@@ -45,7 +45,7 @@ AG_GST_LIBTOOL_PREPARE
AS_LIBTOOL(GST, 0, 0, 0)
dnl *** required versions of GStreamer stuff ***
-GST_REQ=0.11.99
+GST_REQ=1.0.0
ORC_REQ=0.4.16
ORC_CHECK([$ORC_REQ])
diff --git a/gst-libav.doap b/gst-libav.doap
index 64039aa..9ab83be 100644
--- a/gst-libav.doap
+++ b/gst-libav.doap
@@ -34,6 +34,16 @@ colorspace conversion elements.
<release>
<Version>
+ <revision>1.0.0</revision>
+ <branch>1.0</branch>
+ <name></name>
+ <created>2012-09-24</created>
+ <file-release rdf:resource="http://gstreamer.freedesktop.org/src/gst-libav/gst-libav-1.0.0.tar.xz" />
+ </Version>
+ </release>
+
+ <release>
+ <Version>
<revision>0.11.99</revision>
<branch>0.11</branch>
<name>Have Some Courtesy</name>
diff --git a/gst-libav.spec b/gst-libav.spec
index d9cb6e9..3c785a3 100644
--- a/gst-libav.spec
+++ b/gst-libav.spec
@@ -4,7 +4,7 @@
%define gst_majorminor 1.0
Name: %{gstreamer}-libav
-Version: 0.11.99
+Version: 1.0.0
Release: 1
Summary: GStreamer Streaming-media framework plug-in using libav (FFmpeg).
Group: Libraries/Multimedia
diff --git a/tests/check/elements/avdec_adpcm.c b/tests/check/elements/avdec_adpcm.c
index 295e753..8cf9f6f 100644
--- a/tests/check/elements/avdec_adpcm.c
+++ b/tests/check/elements/avdec_adpcm.c
@@ -160,7 +160,7 @@ avdec_adpcm_suite (void)
TCase *tc_chain = tcase_create ("general");
suite_add_tcase (s, tc_chain);
- tcase_add_test (tc_chain, test_low_sample_rate_adpcm);
+ tcase_skip_broken_test (tc_chain, test_low_sample_rate_adpcm);
return s;
}
diff --git a/tests/check/elements/avdemux_ape.c b/tests/check/elements/avdemux_ape.c
index 3751fc5..ddc2f88 100644
--- a/tests/check/elements/avdemux_ape.c
+++ b/tests/check/elements/avdemux_ape.c
@@ -198,7 +198,7 @@ avdemux_ape_suite (void)
TCase *tc_chain = tcase_create ("general");
suite_add_tcase (s, tc_chain);
- tcase_add_test (tc_chain, test_tag_caching);
+ tcase_skip_broken_test (tc_chain, test_tag_caching);
return s;
}