aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian@centricular.com>2014-02-09 12:49:43 +0100
committerSebastian Dröge <sebastian@centricular.com>2014-02-09 12:49:43 +0100
commitf91f8fd452be2f9f926ed06a8e9f4b5a77ea9ef5 (patch)
tree053ca1d60c7c13cefd518dad09811b237e65c77d
parent32ed99bc8567ddad23ad00be4a686270ba212808 (diff)
Fix linking of opencv plugin by working around yet again broken opencv pkg-config filedebian/1.2.3-1
-rw-r--r--debian/build-deps1
-rw-r--r--debian/build-deps.in1
-rw-r--r--debian/changelog6
-rw-r--r--debian/control1
-rw-r--r--debian/patches/02_opencv-linking.patch15
-rw-r--r--debian/patches/series1
6 files changed, 19 insertions, 6 deletions
diff --git a/debian/build-deps b/debian/build-deps
index fbfd9e9a..9a4176ff 100644
--- a/debian/build-deps
+++ b/debian/build-deps
@@ -46,7 +46,6 @@ libmpg123-dev (>= 1.13)
libofa0-dev (>= 0.9.3)
libopenal-dev (>= 1:1.14)
libopencv-dev (>= 2.0.0)
-libopencv-ocl2.4
libopenjpeg-dev
libopus-dev (>= 0.9.4)
liborc-0.4-dev (>= 1:0.4.17)
diff --git a/debian/build-deps.in b/debian/build-deps.in
index 8bd1a2c3..d97ab714 100644
--- a/debian/build-deps.in
+++ b/debian/build-deps.in
@@ -66,7 +66,6 @@ libxml2-dev (>= 2.4)
libfluidsynth-dev (>= 1.0)
libsrtp0-dev
libopencv-dev (>= 2.0.0)
-libopencv-ocl2.4
libopenjpeg-dev
libgnutls-dev (>= 2.11.3)
libchromaprint-dev
diff --git a/debian/changelog b/debian/changelog
index d618e6f6..236e4c9f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,9 +7,9 @@ gst-plugins-bad1.0 (1.2.3-1) unstable; urgency=medium
[ Sebastian Dröge ]
* New upstream bugfix release.
- * debian/build-deps.in:
- + Build-depend on libopencv-ocl2.4 until the dependencies of
- libopencv-dev are fixed once again.
+ * debian/patches/02_opencv-linking.patch:
+ + Fix linking of opencv plugin by working around yet again broken
+ opencv pkg-config file.
-- Sebastian Dröge <slomo@debian.org> Sun, 09 Feb 2014 11:37:09 +0100
diff --git a/debian/control b/debian/control
index 992715ff..356a1ece 100644
--- a/debian/control
+++ b/debian/control
@@ -58,7 +58,6 @@ Build-Depends: autoconf (>= 2.62),
libofa0-dev (>= 0.9.3),
libopenal-dev (>= 1:1.14),
libopencv-dev (>= 2.0.0),
- libopencv-ocl2.4,
libopenjpeg-dev,
libopus-dev (>= 0.9.4),
liborc-0.4-dev (>= 1:0.4.17),
diff --git a/debian/patches/02_opencv-linking.patch b/debian/patches/02_opencv-linking.patch
new file mode 100644
index 00000000..a199f6f5
--- /dev/null
+++ b/debian/patches/02_opencv-linking.patch
@@ -0,0 +1,15 @@
+diff --git a/ext/opencv/Makefile.am b/ext/opencv/Makefile.am
+index 3ba1c34..2bda4e3 100644
+--- a/ext/opencv/Makefile.am
++++ b/ext/opencv/Makefile.am
+@@ -40,7 +40,9 @@ libgstopencv_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) \
+ -DCV_INLINE="static inline" \
+ -DCV_NO_BACKWARD_COMPATIBILITY
+
+-libgstopencv_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS) $(OPENCV_LIBS) \
++# workaround for broken pkg-config file
++OPENCV_LIBS_FIXED = $(subst ocl,ml,$(OPENCV_LIBS))
++libgstopencv_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS) $(OPENCV_LIBS_FIXED) \
+ $(GSTPB_BASE_LIBS) -lgstvideo-$(GST_API_VERSION)
+
+ libgstopencv_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
diff --git a/debian/patches/series b/debian/patches/series
index 6d1fff2e..6d982195 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
01_fix-modplug-linking.patch
+02_opencv-linking.patch