aboutsummaryrefslogtreecommitdiff
path: root/debian/mk.control
diff options
context:
space:
mode:
authorOlivier Naudan <o-naudan@ti.com>2012-04-17 06:58:02 -0400
committerOlivier Naudan <o-naudan@ti.com>2012-04-17 06:58:02 -0400
commit46788ea9f36df26c74c5b55401ff1d9b94ad4715 (patch)
tree62a9852a8aa52f6921656a810f66e371e8d165ab /debian/mk.control
parent2556a70694fc4543759f0d26a8b31d649b4cc72e (diff)
Imported debian/ from gst-plugins-ugly version 0.10.19-1
Diffstat (limited to 'debian/mk.control')
-rwxr-xr-xdebian/mk.control17
1 files changed, 17 insertions, 0 deletions
diff --git a/debian/mk.control b/debian/mk.control
new file mode 100755
index 0000000..e69cbf7
--- /dev/null
+++ b/debian/mk.control
@@ -0,0 +1,17 @@
+#!/usr/bin/perl -w
+
+open BUILDDEPS, "debian/build-deps";
+@builddeplist = <BUILDDEPS>;
+close BUILDDEPS;
+
+chomp(@builddeplist);
+@builddeplist = grep(!/^$/, @builddeplist);
+$builddeps = join(", ", @builddeplist);
+
+open CONTROLIN, "debian/control.in";
+
+while(<CONTROLIN>){
+ s/BUILDDEPS/$builddeps/;
+ print;
+}
+