aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 6 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index c3ba492..a810fee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,7 +5,7 @@ dnl please read gstreamer/docs/random/autotools before changing this file
dnl initialize autoconf
dnl releases only do -Wall, cvs and prerelease does -Werror too
dnl use a three digit version number for releases, and four for cvs/prerelease
-AC_INIT(GStreamer Ugly Plug-ins, 0.11.92,
+AC_INIT(GStreamer Ugly Plug-ins, 0.11.93,
http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer,
gst-plugins-ugly)
@@ -47,8 +47,8 @@ AC_DEFINE_UNQUOTED(GST_API_VERSION, "$GST_API_VERSION",
AS_LIBTOOL(GST, 0, 0, 0)
dnl *** required versions of GStreamer stuff ***
-GST_REQ=0.11.91
-GSTPB_REQ=0.11.91
+GST_REQ=0.11.93
+GSTPB_REQ=0.11.93
dnl *** autotools stuff ****
@@ -149,10 +149,10 @@ AG_GST_CHECK_FUNCTION
dnl *** checks for dependency libraries ***
dnl GLib is required
-GLIB_REQ=2.31.14
+GLIB_REQ=2.32.0
AG_GST_GLIB_CHECK([$GLIB_REQ])
-ORC_CHECK([0.4.6])
+ORC_CHECK([0.4.16])
dnl checks for gstreamer
dnl uninstalled is selected preferentially -- see pkg-config(1)
@@ -218,7 +218,6 @@ AG_GST_CHECK_PLUGIN(dvdlpcmdec)
AG_GST_CHECK_PLUGIN(dvdsub)
AG_GST_CHECK_PLUGIN(xingmux)
AG_GST_CHECK_PLUGIN(realmedia)
-AG_GST_CHECK_PLUGIN(synaesthesia)
AC_CHECK_HEADERS([winsock2.h], HAVE_WINSOCK2_H=yes)
@@ -227,11 +226,6 @@ if test "x$HAVE_WINSOCK2_H" = "xyes"; then
AC_SUBST(WIN32_LIBS)
fi
-dnl disable experimental plug-ins
-if test "x$BUILD_EXPERIMENTAL" != "xyes"; then
- AG_GST_DISABLE_PLUGIN(synaesthesia)
-fi
-
dnl *** ext plug-ins ***
dnl keep this list sorted alphabetically !
@@ -357,7 +351,7 @@ AG_GST_CHECK_FEATURE(TWOLAME, [twolame], twolame, [
dnl *** x264 (MPEG-4 part 10/h.264/AVC encoder) ***
translit(dnm, m, l) AM_CONDITIONAL(USE_X264, true)
AG_GST_CHECK_FEATURE(X264, [x264 plug-in], x264, [
- AG_GST_PKG_CHECK_MODULES(X264, x264 >= 0.106.0)
+ AG_GST_PKG_CHECK_MODULES(X264, x264 >= 0.120.0)
])
else
@@ -444,7 +438,6 @@ gst/asfdemux/Makefile
gst/dvdlpcmdec/Makefile
gst/dvdsub/Makefile
gst/realmedia/Makefile
-gst/synaesthesia/Makefile
gst/xingmux/Makefile
ext/Makefile
ext/a52dec/Makefile