aboutsummaryrefslogtreecommitdiff
path: root/docs/libs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/libs/Makefile.am')
-rw-r--r--docs/libs/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/docs/libs/Makefile.am b/docs/libs/Makefile.am
index 0f96f96..60d7318 100644
--- a/docs/libs/Makefile.am
+++ b/docs/libs/Makefile.am
@@ -1,7 +1,7 @@
## Process this file with automake to produce Makefile.in
# The name of the module, e.g. 'glib'.
-#DOC_MODULE=gstreamer-libs-@GST_MAJORMINOR@
+#DOC_MODULE=gstreamer-libs-@GST_API_VERSION@
DOC_MODULE=gstreamer-libs
# don't want $(DOC_MODULE)-scan.c to be built with -Werror
@@ -43,7 +43,6 @@ SCANOBJ_OPTIONS=--type-init-func="g_type_init();gst_init(&argc,&argv)"
IGNORE_HFILES = \
gstinterpolationcontrolsourceprivate.h \
gstlfocontrolsourceprivate.h \
- gstcontrollerprivate.h \
gstgetbits_inl.h \
dp-private.h
@@ -60,9 +59,9 @@ extra_files =
# contains GtkObjects/GObjects and you want to document signals and properties.
GTKDOC_CFLAGS = -I$(top_builddir) -I$(top_builddir)/libs $(GST_OBJ_CFLAGS)
GTKDOC_LIBS = \
- $(top_builddir)/libs/gst/controller/libgstcontroller-@GST_MAJORMINOR@.la \
- $(top_builddir)/libs/gst/base/libgstbase-@GST_MAJORMINOR@.la \
- $(top_builddir)/libs/gst/net/libgstnet-@GST_MAJORMINOR@.la \
+ $(top_builddir)/libs/gst/controller/libgstcontroller-@GST_API_VERSION@.la \
+ $(top_builddir)/libs/gst/base/libgstbase-@GST_API_VERSION@.la \
+ $(top_builddir)/libs/gst/net/libgstnet-@GST_API_VERSION@.la \
$(GST_OBJ_LIBS)
GTKDOC_CC=$(LIBTOOL) --tag=CC --mode=compile $(CC)