aboutsummaryrefslogtreecommitdiff
path: root/gst/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/Makefile.am')
-rw-r--r--gst/Makefile.am96
1 files changed, 45 insertions, 51 deletions
diff --git a/gst/Makefile.am b/gst/Makefile.am
index dcb8c93..542f45d 100644
--- a/gst/Makefile.am
+++ b/gst/Makefile.am
@@ -1,4 +1,4 @@
-lib_LTLIBRARIES = libgstreamer-@GST_MAJORMINOR@.la
+lib_LTLIBRARIES = libgstreamer-@GST_API_VERSION@.la
if GST_DISABLE_REGISTRY
GST_REGISTRY_SRC =
@@ -34,18 +34,18 @@ DIST_SUBDIRS = parse
# distinction clear
built_header_configure = gstconfig.h gstversion.h
-built_header_make = gstenumtypes.h gstmarshal.h
-built_source_make = gstenumtypes.c gstmarshal.c
+built_header_make = gstenumtypes.h
+built_source_make = gstenumtypes.c
-EXTRA_libgstreamer_@GST_MAJORMINOR@_la_SOURCES = \
- gstmarshal.list gsttrace.c \
+EXTRA_libgstreamer_@GST_API_VERSION@_la_SOURCES = \
+ gsttrace.c \
gstregistrybinary.c
# temporarily not used
# glib-compat.c
-libgstreamer_@GST_MAJORMINOR@_la_SOURCES = \
+libgstreamer_@GST_API_VERSION@_la_SOURCES = \
gst.c \
gstobject.c \
gstbin.c \
@@ -56,17 +56,16 @@ libgstreamer_@GST_MAJORMINOR@_la_SOURCES = \
gstcaps.c \
gstchildproxy.c \
gstclock.c \
+ gstcontrolbinding.c \
+ gstcontrolsource.c \
gstdatetime.c \
gstdebugutils.c \
gstelement.c \
gstelementfactory.c \
gsterror.c \
gstevent.c \
- gstfilter.c \
gstformat.c \
gstghostpad.c \
- gstindex.c \
- gstindexfactory.c \
gstinfo.c \
gstiterator.c \
gstatomicqueue.c \
@@ -87,6 +86,7 @@ libgstreamer_@GST_MAJORMINOR@_la_SOURCES = \
gstquery.c \
gstregistry.c \
gstregistrychunks.c \
+ gstsample.c \
gstsegment.c \
gststructure.c \
gstsystemclock.c \
@@ -94,6 +94,8 @@ libgstreamer_@GST_MAJORMINOR@_la_SOURCES = \
gsttagsetter.c \
gsttask.c \
gsttaskpool.c \
+ gsttoc.c \
+ gsttocsetter.c \
$(GST_TRACE_SRC) \
gsttypefind.c \
gsttypefindfactory.c \
@@ -104,7 +106,7 @@ libgstreamer_@GST_MAJORMINOR@_la_SOURCES = \
$(GST_REGISTRY_SRC)
# do not put files in the distribution that are generated
-nodist_libgstreamer_@GST_MAJORMINOR@_la_SOURCES = $(built_source_make)
+nodist_libgstreamer_@GST_API_VERSION@_la_SOURCES = $(built_source_make)
# BUILT_SOURCES are built on make all/check/install before all other targets
BUILT_SOURCES = \
@@ -116,25 +118,25 @@ CLEANFILES = $(built_header_make) $(built_source_make) $(as_dll_cleanfiles) *.gc
# DISTCLEANFILES is for files generated by configure
DISTCLEANFILES = $(built_header_configure)
-libgstreamer_@GST_MAJORMINOR@_la_CFLAGS = \
+libgstreamer_@GST_API_VERSION@_la_CFLAGS = \
-D_GNU_SOURCE \
-DGST_EXPORTS \
-DG_LOG_DOMAIN=g_log_domain_gstreamer \
- -DGST_MAJORMINOR=\""$(GST_MAJORMINOR)"\" \
+ -DGST_API_VERSION=\""$(GST_API_VERSION)"\" \
-DGST_DISABLE_DEPRECATED \
$(VALGRIND_CFLAGS) \
$(GST_ALL_CFLAGS)
-libgstreamer_@GST_MAJORMINOR@_la_LIBADD = \
+libgstreamer_@GST_API_VERSION@_la_LIBADD = \
$(GST_PARSE_LA) \
$(GST_ALL_LIBS) \
$(WIN32_LIBS) \
$(LIBM)
-libgstreamer_@GST_MAJORMINOR@_la_LDFLAGS = \
+libgstreamer_@GST_API_VERSION@_la_LDFLAGS = \
$(GST_LIB_LDFLAGS) $(GST_ALL_LDFLAGS) $(GST_LT_LDFLAGS)
-libgstreamer_@GST_MAJORMINOR@includedir = $(includedir)/gstreamer-@GST_MAJORMINOR@/gst
+libgstreamer_@GST_API_VERSION@includedir = $(includedir)/gstreamer-@GST_API_VERSION@/gst
gst_headers = \
gst.h \
@@ -149,6 +151,8 @@ gst_headers = \
gstchildproxy.h \
gstclock.h \
gstcompat.h \
+ gstcontrolbinding.h \
+ gstcontrolsource.h \
gstdatetime.h \
gstdebugutils.h \
gstelement.h \
@@ -156,11 +160,8 @@ gst_headers = \
gstelementfactory.h \
gsterror.h \
gstevent.h \
- gstfilter.h \
gstformat.h \
gstghostpad.h \
- gstindex.h \
- gstindexfactory.h \
gstinfo.h \
gstiterator.h \
gstatomicqueue.h \
@@ -178,6 +179,7 @@ gst_headers = \
gstpoll.h \
gstpreset.h \
gstquery.h \
+ gstsample.h \
gstsegment.h \
gststructure.h \
gstsystemclock.h \
@@ -185,7 +187,8 @@ gst_headers = \
gsttagsetter.h \
gsttask.h \
gsttaskpool.h \
- gsttrace.h \
+ gsttoc.h \
+ gsttocsetter.h \
gsttypefind.h \
gsttypefindfactory.h \
gsturi.h \
@@ -194,9 +197,9 @@ gst_headers = \
gstregistry.h \
gstparse.h
-libgstreamer_@GST_MAJORMINOR@include_HEADERS = $(gst_headers) math-compat.h
+libgstreamer_@GST_API_VERSION@include_HEADERS = $(gst_headers) math-compat.h
-nodist_libgstreamer_@GST_MAJORMINOR@include_HEADERS = \
+nodist_libgstreamer_@GST_API_VERSION@include_HEADERS = \
$(built_header_configure) $(built_header_make)
noinst_HEADERS = \
@@ -209,19 +212,9 @@ noinst_HEADERS = \
gstquark.h \
gstregistrybinary.h \
gstregistrychunks.h \
+ gsttrace.h \
gst_private.h
-gstmarshal.h: gstmarshal.list
- $(AM_V_GEN)glib-genmarshal --header --prefix=gst_marshal $(srcdir)/gstmarshal.list > gstmarshal.h.tmp && \
- mv gstmarshal.h.tmp gstmarshal.h
-
-gstmarshal.c: gstmarshal.list gst_private.h
- $(AM_V_GEN)echo "#include \"gst_private.h\"" > gstmarshal.c.tmp && \
- echo "#include \"glib-object.h\"" >> gstmarshal.c.tmp && \
- echo "#include \"gstmarshal.h\"" >> gstmarshal.c.tmp && \
- glib-genmarshal --body --prefix=gst_marshal $(srcdir)/gstmarshal.list >> gstmarshal.c.tmp && \
- mv gstmarshal.c.tmp gstmarshal.c
-
gstenumtypes.h: $(gst_headers)
$(AM_V_GEN)glib-mkenums \
--fhead "#ifndef __GST_ENUM_TYPES_H__\n#define __GST_ENUM_TYPES_H__\n\n#include <glib-object.h>\n\nG_BEGIN_DECLS\n" \
@@ -239,44 +232,45 @@ gstenumtypes.c: $(gst_headers)
--vtail " { 0, NULL, NULL }\n };\n\n if (g_once_init_enter (&id)) {\n GType tmp = g_@type@_register_static (\"@EnumName@\", values);\n g_once_init_leave (&id, tmp);\n }\n\n return (GType) id;\n}" \
$^ > gstenumtypes.c
-%.c.gcov: .libs/libgstreamer_@GST_MAJORMINOR@_la-%.gcda %.c
+%.c.gcov: .libs/libgstreamer_@GST_API_VERSION@_la-%.gcda %.c
$(GCOV) -b -f -o $^ > $@.out
-gcov: $(libgstreamer_@GST_MAJORMINOR@_la_SOURCES:=.gcov)
+gcov: $(libgstreamer_@GST_API_VERSION@_la_SOURCES:=.gcov)
Android.mk: Makefile.am
- androgenizer -:PROJECT gstreamer -:SHARED libgstreamer-@GST_MAJORMINOR@ \
+ androgenizer -:PROJECT gstreamer -:SHARED libgstreamer-@GST_API_VERSION@ \
-:TAGS eng debug \
-:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
- -:SOURCES $(libgstreamer_@GST_MAJORMINOR@_la_SOURCES) \
- $(nodist_libgstreamer_@GST_MAJORMINOR@_la_SOURCES) \
- -:CFLAGS $(DEFS) $(libgstreamer_@GST_MAJORMINOR@_la_CFLAGS) \
- -:LDFLAGS $(libgstreamer_@GST_MAJORMINOR@_la_LDFLAGS) \
- $(libgstreamer_@GST_MAJORMINOR@_la_LIBADD) \
+ -:SOURCES $(libgstreamer_@GST_API_VERSION@_la_SOURCES) \
+ $(nodist_libgstreamer_@GST_API_VERSION@_la_SOURCES) \
+ -:CFLAGS $(DEFS) $(libgstreamer_@GST_API_VERSION@_la_CFLAGS) \
+ -:LDFLAGS $(libgstreamer_@GST_API_VERSION@_la_LDFLAGS) \
+ $(libgstreamer_@GST_API_VERSION@_la_LIBADD) \
-ldl \
-:SUBDIR gst/parse \
- -:HEADER_TARGET gstreamer-@GST_MAJORMINOR@/gst \
- -:HEADERS $(libgstreamer_@GST_MAJORMINOR@include_HEADERS) \
+ -:HEADER_TARGET gstreamer-@GST_API_VERSION@/gst \
+ -:HEADERS $(libgstreamer_@GST_API_VERSION@include_HEADERS) \
-:LIBFILTER_STATIC gstparse \
-:PASSTHROUGH LOCAL_ARM_MODE:=arm \
> $@
if HAVE_INTROSPECTION
-BUILT_GIRSOURCES = Gst-@GST_MAJORMINOR@.gir
+BUILT_GIRSOURCES = Gst-@GST_API_VERSION@.gir
-gir_headers=$(patsubst %,$(srcdir)/%, $(libgstreamer_@GST_MAJORMINOR@include_HEADERS))
-gir_sources=$(patsubst %,$(srcdir)/%, $(libgstreamer_@GST_MAJORMINOR@_la_SOURCES))
+gir_headers=$(patsubst %,$(srcdir)/%, $(libgstreamer_@GST_API_VERSION@include_HEADERS))
+gir_sources=$(patsubst %,$(srcdir)/%, $(libgstreamer_@GST_API_VERSION@_la_SOURCES))
-Gst-@GST_MAJORMINOR@.gir: $(INTROSPECTION_SCANNER) libgstreamer-@GST_MAJORMINOR@.la
+Gst-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstreamer-@GST_API_VERSION@.la
$(AM_V_GEN)GST_PLUGIN_SYSTEM_PATH="" GST_PLUGIN_PATH="" GST_REGISTRY_UPDATE=no \
$(INTROSPECTION_SCANNER) -v --namespace Gst \
- --nsversion=@GST_MAJORMINOR@ \
+ --nsversion=@GST_API_VERSION@ \
+ --warn-all \
-I$(top_srcdir) \
-I$(top_builddir) \
-DIN_GOBJECT_INTROSPECTION=1 \
-DGST_USE_UNSTABLE_API \
--c-include='gst/gst.h' \
- --library=libgstreamer-0.11.la \
+ --library=libgstreamer-@GST_API_VERSION@.la \
--include=GLib-2.0 \
--include=GObject-2.0 \
--include=GModule-2.0 \
@@ -285,7 +279,7 @@ Gst-@GST_MAJORMINOR@.gir: $(INTROSPECTION_SCANNER) libgstreamer-@GST_MAJORMINOR@
--pkg gobject-2.0 \
--pkg gmodule-no-export-2.0 \
--pkg gthread-2.0 \
- --pkg-export gstreamer-@GST_MAJORMINOR@ \
+ --pkg-export gstreamer-@GST_API_VERSION@ \
--add-init-section="gst_init(NULL, NULL);" \
--output $@ \
$(gir_headers) \
@@ -308,11 +302,11 @@ endif
# try to prevent packaging errors
check-libexecdir-consistency:
- @if test "${GST_PLUGIN_SCANNER_INSTALLED}" != "${libexecdir}/gstreamer-$(GST_MAJORMINOR)/gst-plugin-scanner"; then \
+ @if test "${GST_PLUGIN_SCANNER_INSTALLED}" != "${libexecdir}/gstreamer-$(GST_API_VERSION)/gst-plugin-scanner"; then \
echo "*** Inconsistent libexecdir! Please use ./configure --libexecdir=/foo/bar"; \
echo "*** to set the libexecdir and not make libexecdir=/foo/bar or the like."; \
echo "*** The same goes for prefix, libdir etc."; \
- echo "*** ${GST_PLUGIN_SCANNER_INSTALLED} != ${libexecdir}/gstreamer-$(GST_MAJORMINOR)/gst-plugin-scanner"; \
+ echo "*** ${GST_PLUGIN_SCANNER_INSTALLED} != ${libexecdir}/gstreamer-$(GST_API_VERSION)/gst-plugin-scanner"; \
exit 1; \
fi