aboutsummaryrefslogtreecommitdiff
path: root/pkgconfig/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pkgconfig/Makefile.am')
-rw-r--r--pkgconfig/Makefile.am28
1 files changed, 12 insertions, 16 deletions
diff --git a/pkgconfig/Makefile.am b/pkgconfig/Makefile.am
index c928f25..5da63ed 100644
--- a/pkgconfig/Makefile.am
+++ b/pkgconfig/Makefile.am
@@ -1,27 +1,25 @@
### all of the standard pc files we need to generate
if HAVE_CHECK
-CHECK_PC_I = gstreamer-check-@GST_MAJORMINOR@.pc
-CHECK_PC_U = gstreamer-check-@GST_MAJORMINOR@-uninstalled.pc
+CHECK_PC_I = gstreamer-check-@GST_API_VERSION@.pc
+CHECK_PC_U = gstreamer-check-@GST_API_VERSION@-uninstalled.pc
else
CHECK_PC_I =
CHECK_PC_U =
endif
pcfiles = \
- gstreamer-@GST_MAJORMINOR@.pc \
- gstreamer-base-@GST_MAJORMINOR@.pc \
+ gstreamer-@GST_API_VERSION@.pc \
+ gstreamer-base-@GST_API_VERSION@.pc \
$(CHECK_PC_I) \
- gstreamer-controller-@GST_MAJORMINOR@.pc \
- gstreamer-dataprotocol-@GST_MAJORMINOR@.pc \
- gstreamer-net-@GST_MAJORMINOR@.pc
+ gstreamer-controller-@GST_API_VERSION@.pc \
+ gstreamer-net-@GST_API_VERSION@.pc
pcfiles_uninstalled = \
- gstreamer-@GST_MAJORMINOR@-uninstalled.pc \
- gstreamer-base-@GST_MAJORMINOR@-uninstalled.pc \
+ gstreamer-@GST_API_VERSION@-uninstalled.pc \
+ gstreamer-base-@GST_API_VERSION@-uninstalled.pc \
$(CHECK_PC_U) \
- gstreamer-controller-@GST_MAJORMINOR@-uninstalled.pc \
- gstreamer-dataprotocol-@GST_MAJORMINOR@-uninstalled.pc \
- gstreamer-net-@GST_MAJORMINOR@-uninstalled.pc
+ gstreamer-controller-@GST_API_VERSION@-uninstalled.pc \
+ gstreamer-net-@GST_API_VERSION@-uninstalled.pc
all-local: $(pcfiles) $(pcfiles_uninstalled)
@@ -30,9 +28,9 @@ cp_verbose_ = $(cp_verbose_$(AM_DEFAULT_VERBOSITY))
cp_verbose_0 = @echo " CP $@";
### how to generate pc files
-%-@GST_MAJORMINOR@.pc: %.pc
+%-@GST_API_VERSION@.pc: %.pc
$(cp_verbose_0)cp $< $@
-%-@GST_MAJORMINOR@-uninstalled.pc: %-uninstalled.pc
+%-@GST_API_VERSION@-uninstalled.pc: %-uninstalled.pc
$(cp_verbose_0)cp $< $@
pkgconfigdir = $(libdir)/pkgconfig
@@ -47,8 +45,6 @@ EXTRA_DIST = \
gstreamer-check-uninstalled.pc.in \
gstreamer-controller.pc.in \
gstreamer-controller-uninstalled.pc.in \
- gstreamer-dataprotocol.pc.in \
- gstreamer-dataprotocol-uninstalled.pc.in \
gstreamer-net.pc.in \
gstreamer-net-uninstalled.pc.in