aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Harkin <ryan.harkin@linaro.org>2020-05-06 14:58:48 +0100
committerRyan Harkin <ryan.harkin@linaro.org>2020-05-06 14:59:38 +0100
commitbcf91bc2850790aec41e6dc10aa58b6e8fc4617c (patch)
treecc11b924ba3efebad961a854517aecd4d04be54d
parent60c8204ea161297d8255d44a9dc46ecbfc9a24e3 (diff)
layer.conf: use BBFILES_DYNAMICHEADmaster
Only include .bbappend and .bb files for layers already present in BBFILES_DYNAMIC. This prevents build failures from attempting to patch layers that do not exist. Signed-off-by: Ryan Harkin <ryan.harkin@linaro.org> Change-Id: I252c4d2b54f1ef93480c32a68d0f4d3ed5c4054a
-rw-r--r--conf/layer.conf4
1 files changed, 2 insertions, 2 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index e961f84..d8fe9ac 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -8,8 +8,8 @@ BBFILE_PRIORITY_backports = "5"
# Let us add layer-specific bbappends which are only applied when that
# layer is included in our configuration
# includes customization and/or backports
-BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
+BBFILES_DYNAMIC += "${@' '.join('%s:${LAYERDIR}/%s/recipes*/*/*.bbappend' % (layer, layer) \
for layer in BBFILE_COLLECTIONS.split())}"
# Add layer-specific bb files too
-BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
+BBFILES_DYNAMIC += "${@' '.join('%s:${LAYERDIR}/%s/recipes*/*/*.bb' % (layer, layer) \
for layer in BBFILE_COLLECTIONS.split())}"