aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Díaz <daniel.diaz@linaro.org>2018-06-27 12:46:38 -0500
committerFathi Boudra <fathi.boudra@linaro.org>2018-06-27 19:12:17 +0000
commit02ea49df31d46d00d1f7cf6ecba4a0c6c7a9e45c (patch)
treefae1ca95024d4ba26056e85c2e8b534d0b6e2bab
parent8f49ed994348d9a81444bed4c70c37a8b68f4856 (diff)
bpftool: add new recipe
The bpftool allows for inspection and simple manipulation of eBPF programs and maps, so common in the kernel selftests. Change-Id: I9a8b2476bcd1268c98c89f1d43656c5441e29eb9 Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org> (cherry picked from commit 4c9df2f4825276805e7fd2846c9e052be9b8442a)
-rw-r--r--openembedded-layer/recipes-kernel/bpftool/bpftool.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/openembedded-layer/recipes-kernel/bpftool/bpftool.bb b/openembedded-layer/recipes-kernel/bpftool/bpftool.bb
new file mode 100644
index 0000000..fd0653a
--- /dev/null
+++ b/openembedded-layer/recipes-kernel/bpftool/bpftool.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Inspect and manipulate eBPF programs and maps"
+DESCRIPTION = "bpftool is a kernel tool for inspection and simple manipulation \
+of eBPF programs and maps."
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = "binutils elfutils"
+PROVIDES = "virtual/bpftool"
+
+inherit bash-completion kernelsrc kernel-arch
+
+do_populate_lic[depends] += "virtual/kernel:do_patch"
+
+EXTRA_OEMAKE = "-C ${S}/tools/bpf/bpftool O=${B} CROSS=${TARGET_PREFIX} CC="${CC}" LD="${LD}" AR=${AR} ARCH=${ARCH}"
+
+do_configure[depends] += "virtual/kernel:do_shared_workdir"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+python do_package_prepend() {
+ d.setVar('PKGV', d.getVar("KERNEL_VERSION", True).split("-")[0])
+}
+
+B = "${WORKDIR}/${BPN}-${PV}"