aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Konovalov <andrey.konovalov@linaro.org>2019-08-19 18:16:07 +0200
committerAndrey Konovalov <andrey.konovalov@linaro.org>2019-08-20 13:40:44 +0300
commit332d20161dbe17d43df93f77dd18068af906cd3e (patch)
treef3e211183a9ed81c5fe3cbbb07d519b7942b30ff
parent2315f95a664a2d3e2f4eee27a1ca926a4c378a5c (diff)
libedit: Upgrade to 20181209 and add native and nativesdk incarnationsthud
This is essentially the cherry pick of meta-oe commit 039f5243b1. Adding BBCLASSEXTEND = "native nativesdk" fixes the below clang build failure: "ERROR: Nothing PROVIDES 'nativesdk-libedit'". Signed-off-by: Andrey Konovalov <andrey.konovalov@linaro.org> Change-Id: I2f712832d6ee903fda5c57d53ce3d2569590a158
-rw-r--r--openembedded-layer/recipes-devtools/libedit/libedit/stdc-predef.patch17
-rw-r--r--openembedded-layer/recipes-devtools/libedit/libedit_20181209-3.1.bb23
2 files changed, 40 insertions, 0 deletions
diff --git a/openembedded-layer/recipes-devtools/libedit/libedit/stdc-predef.patch b/openembedded-layer/recipes-devtools/libedit/libedit/stdc-predef.patch
new file mode 100644
index 0000000..c95cdc9
--- /dev/null
+++ b/openembedded-layer/recipes-devtools/libedit/libedit/stdc-predef.patch
@@ -0,0 +1,17 @@
+__STDC_ISO_10646__ is defined in stdc-predef.h
+therefore include it to see if its there on a platform
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: libedit-20160903-3.1/src/chartype.h
+===================================================================
+--- libedit-20160903-3.1.orig/src/chartype.h
++++ libedit-20160903-3.1/src/chartype.h
+@@ -29,6 +29,7 @@
+ #ifndef _h_chartype_f
+ #define _h_chartype_f
+
++#include <stdc-predef.h>
+ /* Ideally we should also test the value of the define to see if it
+ * supports non-BMP code points without requiring UTF-16, but nothing
+ * seems to actually advertise this properly, despite Unicode 3.1 having
diff --git a/openembedded-layer/recipes-devtools/libedit/libedit_20181209-3.1.bb b/openembedded-layer/recipes-devtools/libedit/libedit_20181209-3.1.bb
new file mode 100644
index 0000000..c0a3d21
--- /dev/null
+++ b/openembedded-layer/recipes-devtools/libedit/libedit_20181209-3.1.bb
@@ -0,0 +1,23 @@
+SUMMARY = "BSD replacement for libreadline"
+DESCRIPTION = "Command line editor library providing generic line editing, \
+history, and tokenization functions"
+HOMEPAGE = "http://www.thrysoee.dk/editline/"
+SECTION = "libs"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1e4228d0c5a9093b01aeaaeae6641533"
+
+DEPENDS = "ncurses"
+
+inherit autotools
+
+# upstream site does not allow wget's User-Agent
+FETCHCMD_wget += "-U bitbake"
+SRC_URI = "http://www.thrysoee.dk/editline/${BPN}-${PV}.tar.gz \
+ file://stdc-predef.patch \
+ "
+SRC_URI[md5sum] = "22e945a0476e388e6f78bfc8d6e1192c"
+SRC_URI[sha256sum] = "2811d70c0b000f2ca91b7cb1a37203134441743c4fcc9c37b0b687f328611064"
+
+S = "${WORKDIR}/${BPN}-${PV}"
+
+BBCLASSEXTEND = "native nativesdk"