aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Díaz <daniel.diaz@linaro.org>2018-11-07 17:23:55 -0600
committerDaniel Díaz <daniel.diaz@linaro.org>2018-11-07 17:23:55 -0600
commit1d4b400a472a10477bacda582a4724957926ec2f (patch)
tree7615c5c06c7e0d04207eba20533aff3a572dccf5
parentac2777328854ff68bed6bb37df9b0f5440a3068f (diff)
libhugetlbfs: Not a backport, obsolete, removing
The exact same recipe got an update in meta-oe master branch, making the patches here outdated. No functional changes, but still no point in keeping a copy of the same thing. Change-Id: I115933b7700223d3c674b6670c47df302ae2d5e5 Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org>
-rw-r--r--openembedded-layer/recipes-benchmark/libhugetlbfs/files/0001-include-stddef.h-for-ptrdiff_t.patch25
-rw-r--r--openembedded-layer/recipes-benchmark/libhugetlbfs/files/0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch43
-rw-r--r--openembedded-layer/recipes-benchmark/libhugetlbfs/files/0002-Mark-glibc-specific-code-so.patch39
-rw-r--r--openembedded-layer/recipes-benchmark/libhugetlbfs/files/0003-alloc.c-Avoid-sysconf-_SC_LEVEL2_CACHE_LINESIZE-on-l.patch49
-rw-r--r--openembedded-layer/recipes-benchmark/libhugetlbfs/files/0004-shm.c-Mark-glibc-specific-changes-so.patch30
-rw-r--r--openembedded-layer/recipes-benchmark/libhugetlbfs/files/0005-Include-dirent.h-for-ino_t.patch28
-rw-r--r--openembedded-layer/recipes-benchmark/libhugetlbfs/files/0006-include-limits.h-for-PATH_MAX.patch42
-rw-r--r--openembedded-layer/recipes-benchmark/libhugetlbfs/files/libhugetlbfs-avoid-search-host-library-path-for-cros.patch99
-rw-r--r--openembedded-layer/recipes-benchmark/libhugetlbfs/files/libhugetlbfs-elf_i386-avoid-search-host-library-path.patch40
-rw-r--r--openembedded-layer/recipes-benchmark/libhugetlbfs/files/skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch23
-rw-r--r--openembedded-layer/recipes-benchmark/libhugetlbfs/files/tests-Makefile-install-static-4G-edge-testcases.patch17
-rw-r--r--openembedded-layer/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb72
12 files changed, 0 insertions, 507 deletions
diff --git a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0001-include-stddef.h-for-ptrdiff_t.patch b/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0001-include-stddef.h-for-ptrdiff_t.patch
deleted file mode 100644
index bae90b4..0000000
--- a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0001-include-stddef.h-for-ptrdiff_t.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From d3c2187716a0a1f9359a869ca383c129603554d9 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 21 Jun 2018 19:25:57 -0700
-Subject: [PATCH 1/6] include stddef.h for ptrdiff_t
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- morecore.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/morecore.c b/morecore.c
-index 62ad252..c5981d2 100644
---- a/morecore.c
-+++ b/morecore.c
-@@ -19,6 +19,7 @@
-
- #define _GNU_SOURCE
-
-+#include <stddef.h>
- #include <stdio.h>
- #include <stdlib.h>
- #include <malloc.h>
---
-2.17.1
-
diff --git a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch b/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch
deleted file mode 100644
index 3082d7e..0000000
--- a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From a85fc43243f8bfad12d306a4a0e230fb8b3e828a Mon Sep 17 00:00:00 2001
-From: Ting Liu <b28495@freescale.com>
-Date: Wed, 21 Aug 2013 15:44:57 +0800
-Subject: [PATCH] run_test.py: not use hard coded path ../obj/hugeadm
-
-Hard coded path makes the script impossible to run out of source tree.
-After 'make install', we can use hugeadm utility under DESTDIR.
-
-Upstream-Status: Submitted
-
-Signed-off-by: Ting Liu <b28495@freescale.com>
----
- tests/run_tests.py | 12 +++++++++++-
- 1 files changed, 11 insertions(+), 1 deletions(-)
-
-diff --git a/tests/run_tests.py b/tests/run_tests.py
-index d9a6b35..a9bab8f 100755
---- a/tests/run_tests.py
-+++ b/tests/run_tests.py
-@@ -232,9 +232,19 @@ def get_pagesizes():
- Use libhugetlbfs' hugeadm utility to get a list of page sizes that have
- active mount points and at least one huge page allocated to the pool.
- """
-+ local_env = os.environ.copy()
-+ local_env["PATH"] = "../obj:%s" % local_env.get("PATH", "")
- sizes = set()
- out = ""
-- (rc, out) = bash("../obj/hugeadm --page-sizes")
-+ try:
-+ p = subprocess.Popen("hugeadm --page-sizes", shell=True, env=local_env, stdout=subprocess.PIPE)
-+ rc = p.wait()
-+ except KeyboardInterrupt:
-+ return sizes
-+ except OSError:
-+ return sizes
-+ out = p.stdout.read().strip()
-+
- if rc != 0 or out == "": return sizes
-
- for size in out.split("\n"): sizes.add(int(size))
---
-1.7.3.4
-
diff --git a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0002-Mark-glibc-specific-code-so.patch b/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0002-Mark-glibc-specific-code-so.patch
deleted file mode 100644
index 4354d78..0000000
--- a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0002-Mark-glibc-specific-code-so.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From b72bf6a81fa879f32a074fe53776fc8291c83b6f Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 21 Jun 2018 19:32:59 -0700
-Subject: [PATCH 2/6] Mark glibc specific code so
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- morecore.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/morecore.c b/morecore.c
-index c5981d2..ec9fafa 100644
---- a/morecore.c
-+++ b/morecore.c
-@@ -347,6 +347,7 @@ void hugetlbfs_setup_morecore(void)
-
- INFO("setup_morecore(): heapaddr = 0x%lx\n", heapaddr);
-
-+#ifdef __GLIBC__
- heaptop = heapbase = (void *)heapaddr;
- if (__hugetlb_opts.thp_morecore)
- __morecore = &thp_morecore;
-@@ -354,7 +355,6 @@ void hugetlbfs_setup_morecore(void)
- __morecore = &hugetlbfs_morecore;
-
- /* Set some allocator options more appropriate for hugepages */
--
- if (__hugetlb_opts.shrink_ok)
- mallopt(M_TRIM_THRESHOLD, hpage_size / 2);
- else
-@@ -364,4 +364,5 @@ void hugetlbfs_setup_morecore(void)
- * This doesn't appear to prohibit malloc() from falling back
- * to mmap() if we run out of hugepages. */
- mallopt(M_MMAP_MAX, 0);
-+#endif
- }
---
-2.17.1
-
diff --git a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0003-alloc.c-Avoid-sysconf-_SC_LEVEL2_CACHE_LINESIZE-on-l.patch b/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0003-alloc.c-Avoid-sysconf-_SC_LEVEL2_CACHE_LINESIZE-on-l.patch
deleted file mode 100644
index f6d8a10..0000000
--- a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0003-alloc.c-Avoid-sysconf-_SC_LEVEL2_CACHE_LINESIZE-on-l.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From 3d6ab5ea8e23f96ee6fdd915e05acd9a751dd876 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 21 Jun 2018 19:44:26 -0700
-Subject: [PATCH 3/6] alloc.c: Avoid sysconf(_SC_LEVEL2_CACHE_LINESIZE) on
- linux
-
-musl does not have it
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- alloc.c | 15 ++++++++++++++-
- 1 file changed, 14 insertions(+), 1 deletion(-)
-
-diff --git a/alloc.c b/alloc.c
-index bce9464..cf7eb40 100644
---- a/alloc.c
-+++ b/alloc.c
-@@ -245,6 +245,19 @@ void free_huge_pages(void *ptr)
- __free_huge_pages(ptr, 1);
- }
-
-+static size_t get_cacheline_size() {
-+#if defined(__linux__)
-+ FILE * fp = fopen("/sys/devices/system/cpu/cpu0/cache/index0/coherency_line_size", "r");
-+ unsigned int line_size = 0;
-+ if (fp) {
-+ fscanf(fp, "%d", &line_size);
-+ fclose(fp);
-+ }
-+ return line_size;
-+#else
-+ return sysconf(_SC_LEVEL2_CACHE_LINESIZE);
-+#endif
-+}
- /*
- * Offset the buffer using bytes wasted due to alignment to avoid using the
- * same cache lines for the start of every buffer returned by
-@@ -261,7 +274,7 @@ void *cachecolor(void *buf, size_t len, size_t color_bytes)
-
- /* Lookup our cacheline size once */
- if (cacheline_size == 0) {
-- cacheline_size = sysconf(_SC_LEVEL2_CACHE_LINESIZE);
-+ cacheline_size = get_cacheline_size();
- linemod = time(NULL);
- }
-
---
-2.17.1
-
diff --git a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0004-shm.c-Mark-glibc-specific-changes-so.patch b/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0004-shm.c-Mark-glibc-specific-changes-so.patch
deleted file mode 100644
index 960e152..0000000
--- a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0004-shm.c-Mark-glibc-specific-changes-so.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 7002dec46dae375e8aa1aa8577a5b274c02fc697 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 21 Jun 2018 19:48:04 -0700
-Subject: [PATCH 4/6] shm.c: Mark glibc specific changes so
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- shm.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/shm.c b/shm.c
-index 1f82cab..9447b63 100644
---- a/shm.c
-+++ b/shm.c
-@@ -48,10 +48,11 @@
- * system shmget() may be performed without worry as there is no dynamic
- * call chain.
- */
-+#ifdef __GLIBC__
- extern void *dlsym (void *__restrict __handle, __const char *__restrict __name)
- __attribute__((weak)) __THROW __nonnull ((2));
- extern char *dlerror (void) __attribute__((weak)) __THROW;
--
-+#endif
-
- /* call syscall shmget through the generic syscall mechanism */
- static int syscall_shmget(key_t key, size_t size, int shmflg)
---
-2.17.1
-
diff --git a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0005-Include-dirent.h-for-ino_t.patch b/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0005-Include-dirent.h-for-ino_t.patch
deleted file mode 100644
index 543302b..0000000
--- a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0005-Include-dirent.h-for-ino_t.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 87ed1706f426ed27fc4eeca7c3b09a4086c9a2a9 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 21 Jun 2018 19:51:02 -0700
-Subject: [PATCH 5/6] Include dirent.h for ino_t
-
-Fixes
-error: unknown type name 'ino_t'; did you mean 'int'?
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- tests/hugetests.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/tests/hugetests.h b/tests/hugetests.h
-index 8b1d8d9..056042c 100644
---- a/tests/hugetests.h
-+++ b/tests/hugetests.h
-@@ -22,6 +22,7 @@
-
- #include <errno.h>
- #include <string.h>
-+#include <dirent.h>
-
- #include "libhugetlbfs_privutils.h"
- #include "libhugetlbfs_testprobes.h"
---
-2.17.1
-
diff --git a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0006-include-limits.h-for-PATH_MAX.patch b/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0006-include-limits.h-for-PATH_MAX.patch
deleted file mode 100644
index 35dd6e1..0000000
--- a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/0006-include-limits.h-for-PATH_MAX.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 96c012ea31a2d124528f3b6f3b9857b71b059db3 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 21 Jun 2018 19:58:53 -0700
-Subject: [PATCH 6/6] include limits.h for PATH_MAX
-
-Fixes
-
-error: 'PATH_MAX' undeclared
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- hugeadm.c | 1 +
- tests/gethugepagesizes.c | 1 +
- 2 files changed, 2 insertions(+)
-
-diff --git a/hugeadm.c b/hugeadm.c
-index fe4211d..8db274c 100644
---- a/hugeadm.c
-+++ b/hugeadm.c
-@@ -33,6 +33,7 @@
- #include <grp.h>
- #include <pwd.h>
- #include <fcntl.h>
-+#include <limits.h>
-
- #include <sys/stat.h>
- #include <sys/types.h>
-diff --git a/tests/gethugepagesizes.c b/tests/gethugepagesizes.c
-index 9551b38..2645e3f 100644
---- a/tests/gethugepagesizes.c
-+++ b/tests/gethugepagesizes.c
-@@ -29,6 +29,7 @@
- #include <fcntl.h>
- #include <stdarg.h>
- #include <hugetlbfs.h>
-+#include <limits.h>
-
- #include "hugetests.h"
-
---
-2.17.1
-
diff --git a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/libhugetlbfs-avoid-search-host-library-path-for-cros.patch b/openembedded-layer/recipes-benchmark/libhugetlbfs/files/libhugetlbfs-avoid-search-host-library-path-for-cros.patch
deleted file mode 100644
index b3fd843..0000000
--- a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/libhugetlbfs-avoid-search-host-library-path-for-cros.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-From 0a2877400a086e9d6ddd32a80462b7a931921dc2 Mon Sep 17 00:00:00 2001
-From: Chunrong Guo <B40290@freescale.com>
-Date: Sun, 8 Sep 2013 23:21:49 -0500
-Subject: [PATCH] libhugetlbfs: avoid search host library path for cross
- compilation
-
-Upstream-Status: Inappropriate [oe-core specific]
-
-Signed-off-by: Chunrong Guo <B40290@freescale.com>
----
- ldscripts/elf32ppclinux.xB | 2 +-
- ldscripts/elf32ppclinux.xBDT | 2 +-
- ldscripts/elf64ppc.xB | 2 +-
- ldscripts/elf64ppc.xBDT | 2 +-
- ldscripts/elf_x86_64.xB | 2 +-
- ldscripts/elf_x86_64.xBDT | 2 +-
- 6 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/ldscripts/elf32ppclinux.xB b/ldscripts/elf32ppclinux.xB
-index 28ad88d..33d482d 100644
---- a/ldscripts/elf32ppclinux.xB
-+++ b/ldscripts/elf32ppclinux.xB
-@@ -3,7 +3,7 @@ OUTPUT_FORMAT("elf32-powerpc", "elf32-powerpc",
- "elf32-powerpc")
- OUTPUT_ARCH(powerpc:common)
- ENTRY(_start)
--SEARCH_DIR("/usr/powerpc-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");
-+/*SEARCH_DIR("/usr/powerpc-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");*/
- INPUT(-lhugetlbfs);
- PHDRS
- {
-diff --git a/ldscripts/elf32ppclinux.xBDT b/ldscripts/elf32ppclinux.xBDT
-index 497882b..823475e 100644
---- a/ldscripts/elf32ppclinux.xBDT
-+++ b/ldscripts/elf32ppclinux.xBDT
-@@ -3,7 +3,7 @@ OUTPUT_FORMAT("elf32-powerpc", "elf32-powerpc",
- "elf32-powerpc")
- OUTPUT_ARCH(powerpc:common)
- ENTRY(_start)
--SEARCH_DIR("/usr/powerpc-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");
-+/*SEARCH_DIR("/usr/powerpc-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");*/
- INPUT(-lhugetlbfs);
- PHDRS
- {
-diff --git a/ldscripts/elf64ppc.xB b/ldscripts/elf64ppc.xB
-index 1a9c1ab..8cc557d 100644
---- a/ldscripts/elf64ppc.xB
-+++ b/ldscripts/elf64ppc.xB
-@@ -3,7 +3,7 @@ OUTPUT_FORMAT("elf64-powerpc", "elf64-powerpc",
- "elf64-powerpc")
- OUTPUT_ARCH(powerpc:common64)
- ENTRY(_start)
--SEARCH_DIR("/usr/powerpc64-linux-gnu/lib64"); SEARCH_DIR("/usr/local/lib64"); SEARCH_DIR("/lib64"); SEARCH_DIR("/usr/lib64"); SEARCH_DIR("/usr/powerpc64-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");
-+/*SEARCH_DIR("/usr/powerpc64-linux-gnu/lib64"); SEARCH_DIR("/usr/local/lib64"); SEARCH_DIR("/lib64"); SEARCH_DIR("/usr/lib64"); SEARCH_DIR("/usr/powerpc64-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");*/
- INPUT(-lhugetlbfs);
- PHDRS
- {
-diff --git a/ldscripts/elf64ppc.xBDT b/ldscripts/elf64ppc.xBDT
-index 5477294..53e0749 100644
---- a/ldscripts/elf64ppc.xBDT
-+++ b/ldscripts/elf64ppc.xBDT
-@@ -3,7 +3,7 @@ OUTPUT_FORMAT("elf64-powerpc", "elf64-powerpc",
- "elf64-powerpc")
- OUTPUT_ARCH(powerpc:common64)
- ENTRY(_start)
--SEARCH_DIR("/usr/powerpc64-linux-gnu/lib64"); SEARCH_DIR("/usr/local/lib64"); SEARCH_DIR("/lib64"); SEARCH_DIR("/usr/lib64"); SEARCH_DIR("/usr/powerpc64-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");
-+/*SEARCH_DIR("/usr/powerpc64-linux-gnu/lib64"); SEARCH_DIR("/usr/local/lib64"); SEARCH_DIR("/lib64"); SEARCH_DIR("/usr/lib64"); SEARCH_DIR("/usr/powerpc64-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");*/
- INPUT( -lhugetlbfs );
- PHDRS
- {
-diff --git a/ldscripts/elf_x86_64.xB b/ldscripts/elf_x86_64.xB
-index ed21a2c..ba50e9f 100644
---- a/ldscripts/elf_x86_64.xB
-+++ b/ldscripts/elf_x86_64.xB
-@@ -3,7 +3,7 @@ OUTPUT_FORMAT("elf64-x86-64", "elf64-x86-64",
- "elf64-x86-64")
- OUTPUT_ARCH(i386:x86-64)
- ENTRY(_start)
--SEARCH_DIR("/usr/x86_64-linux-gnu/lib64"); SEARCH_DIR("/usr/local/lib64"); SEARCH_DIR("/lib64"); SEARCH_DIR("/usr/lib64"); SEARCH_DIR("/usr/x86_64-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");
-+/*SEARCH_DIR("/usr/x86_64-linux-gnu/lib64"); SEARCH_DIR("/usr/local/lib64"); SEARCH_DIR("/lib64"); SEARCH_DIR("/usr/lib64"); SEARCH_DIR("/usr/x86_64-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");*/
- INPUT(-lhugetlbfs);
- /* Do we need any of these for elf?
- __DYNAMIC = 0; */
-diff --git a/ldscripts/elf_x86_64.xBDT b/ldscripts/elf_x86_64.xBDT
-index 1855202..c62d245 100644
---- a/ldscripts/elf_x86_64.xBDT
-+++ b/ldscripts/elf_x86_64.xBDT
-@@ -3,7 +3,7 @@ OUTPUT_FORMAT("elf64-x86-64", "elf64-x86-64",
- "elf64-x86-64")
- OUTPUT_ARCH(i386:x86-64)
- ENTRY(_start)
--SEARCH_DIR("/usr/x86_64-linux-gnu/lib64"); SEARCH_DIR("/usr/local/lib64"); SEARCH_DIR("/lib64"); SEARCH_DIR("/usr/lib64"); SEARCH_DIR("/usr/x86_64-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");
-+/*SEARCH_DIR("/usr/x86_64-linux-gnu/lib64"); SEARCH_DIR("/usr/local/lib64"); SEARCH_DIR("/lib64"); SEARCH_DIR("/usr/lib64"); SEARCH_DIR("/usr/x86_64-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");*/
- INPUT(-lhugetlbfs);
- /* Do we need any of these for elf?
- __DYNAMIC = 0; */
---
-1.7.9.7
-
diff --git a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/libhugetlbfs-elf_i386-avoid-search-host-library-path.patch b/openembedded-layer/recipes-benchmark/libhugetlbfs/files/libhugetlbfs-elf_i386-avoid-search-host-library-path.patch
deleted file mode 100644
index 1566488..0000000
--- a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/libhugetlbfs-elf_i386-avoid-search-host-library-path.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 889e52753d30179ba4ac940023cb4ed561436ab8 Mon Sep 17 00:00:00 2001
-From: Jackie Huang <jackie.huang@windriver.com>
-Date: Tue, 4 Nov 2014 00:49:11 -0800
-Subject: [PATCH] libhugetlbfs/elf_i386: avoid search host library path for cross compilation
-
-Upstream-Status: Inappropriate [cross compile specific]
-
-Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
----
- ldscripts/elf_i386.xB | 1 -
- ldscripts/elf_i386.xBDT | 1 -
- 2 files changed, 2 deletions(-)
-
-diff --git a/ldscripts/elf_i386.xB b/ldscripts/elf_i386.xB
-index 43fe51c..eae0fa8 100644
---- a/ldscripts/elf_i386.xB
-+++ b/ldscripts/elf_i386.xB
-@@ -3,7 +3,6 @@ OUTPUT_FORMAT("elf32-i386", "elf32-i386",
- "elf32-i386")
- OUTPUT_ARCH(i386)
- ENTRY(_start)
--SEARCH_DIR("/usr/i486-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");
- INPUT(-lhugetlbfs);
- /* Do we need any of these for elf?
- __DYNAMIC = 0; */
-diff --git a/ldscripts/elf_i386.xBDT b/ldscripts/elf_i386.xBDT
-index d72aebe..3bac1b1 100644
---- a/ldscripts/elf_i386.xBDT
-+++ b/ldscripts/elf_i386.xBDT
-@@ -3,7 +3,6 @@ OUTPUT_FORMAT("elf32-i386", "elf32-i386",
- "elf32-i386")
- OUTPUT_ARCH(i386)
- ENTRY(_start)
--SEARCH_DIR("/usr/i486-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");
- INPUT(-lhugetlbfs);
- /* Do we need any of these for elf?
- __DYNAMIC = 0; */
---
-1.7.9.5
-
diff --git a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch b/openembedded-layer/recipes-benchmark/libhugetlbfs/files/skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch
deleted file mode 100644
index 07a9971..0000000
--- a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 355c014573de7f95202cc7c819f81f0f230e4a1a Mon Sep 17 00:00:00 2001
-From: Ting Liu <b28495@freescale.com>
-Date: Mon, 18 Jun 2012 16:37:05 +0800
-Subject: [PATCH] skip checking LIB32 and LIB64 if they point to the same place
-
-Upstream-Status: Inappropriate [oe-core specific]
-Signed-off-by: Ting Liu <b28495@freescale.com>
----
-
-diff --git a/Makefile b/Makefile
-index 91502e1..bfb3414 100644
---- a/Makefile
-+++ b/Makefile
-@@ -167,7 +167,6 @@ REALLIB32 = $(realpath $(PREFIX)/$(LIB32))
- REALLIB64 = $(realpath $(PREFIX)/$(LIB64))
- ifneq ($(realpath $(PREFIX)),)
- ifeq ($(REALLIB32),$(REALLIB64))
--$(error LIB32 ($(PREFIX)/$(LIB32) to $(REALLIB32)) and LIB64 ($(PREFIX)/$(LIB64) to $(REALLIB64)) are resolving to the same place. Manually specify LIB32 and LIB64. e.g. make PREFIX=$(PREFIX) LIB32=lib32 LIB64=lib64)
- endif
- endif
-
---
-1.9.2
diff --git a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/tests-Makefile-install-static-4G-edge-testcases.patch b/openembedded-layer/recipes-benchmark/libhugetlbfs/files/tests-Makefile-install-static-4G-edge-testcases.patch
deleted file mode 100644
index 249f6e1..0000000
--- a/openembedded-layer/recipes-benchmark/libhugetlbfs/files/tests-Makefile-install-static-4G-edge-testcases.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Upstream-Status: Submitted
-
-TESTS_64 is empty, install will fail due to missing file operand
-
-Signed-off-by: Ting Liu <b28495@freescale.com>
-
---- a/tests/Makefileold 2013-10-12 02:32:55.262391998 -0500
-+++ b/tests/Makefile 2013-10-12 02:33:45.929394722 -0500
-@@ -292,7 +292,7 @@
- $(INSTALL) -m 755 wrapper-utils.sh $(DESTDIR)$(INST_TESTSDIR64)/obj64
- $(INSTALL) -m 755 $(HELPERS:%=obj64/%) $(DESTDIR)$(INST_TESTSDIR64)/obj64
- $(INSTALL) -m 755 $(HELPER_LIBS:%=obj64/%) $(DESTDIR)$(INST_TESTSDIR64)/obj64
-- $(INSTALL) -m 755 $(TESTS_64:%=obj64/%) $(DESTDIR)$(INST_TESTSDIR64)/obj64
-+ $(INSTALL) -m 755 $(TESTS_64_STATIC:%=obj64/%_static) $(DESTDIR)$(INST_TESTSDIR64)/obj64
- $(INSTALL) -m 755 run_tests.py $(DESTDIR)$(INST_TESTSDIR64)
-
- install: $(OBJDIRS:%=%/install)
diff --git a/openembedded-layer/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/openembedded-layer/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
deleted file mode 100644
index 66fd8e2..0000000
--- a/openembedded-layer/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
+++ /dev/null
@@ -1,72 +0,0 @@
-SUMMARY = "A library which provides easy access to huge pages of memory"
-HOMEPAGE = "https://github.com/libhugetlbfs/libhugetlbfs"
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://LGPL-2.1;md5=2d5025d4aa3495befef8f17206a5b0a1"
-
-DEPENDS = "sysfsutils"
-RDEPENDS_${PN} += "bash python python-io python-lang python-subprocess python-resource"
-RDEPENDS_${PN}-tests += "bash"
-
-PV = "2.21"
-PE = "1"
-
-SRCREV = "73d06e69108f231696e9c5c44f4b42690fc5d752"
-SRC_URI = " \
- git://github.com/libhugetlbfs/libhugetlbfs.git;protocol=https \
- file://skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch \
- file://libhugetlbfs-avoid-search-host-library-path-for-cros.patch \
- file://tests-Makefile-install-static-4G-edge-testcases.patch \
- file://0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch \
- file://libhugetlbfs-elf_i386-avoid-search-host-library-path.patch \
- file://0001-include-stddef.h-for-ptrdiff_t.patch \
- file://0002-Mark-glibc-specific-code-so.patch \
- file://0003-alloc.c-Avoid-sysconf-_SC_LEVEL2_CACHE_LINESIZE-on-l.patch \
- file://0004-shm.c-Mark-glibc-specific-changes-so.patch \
- file://0005-Include-dirent.h-for-ino_t.patch \
- file://0006-include-limits.h-for-PATH_MAX.patch \
-"
-
-UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
-
-S = "${WORKDIR}/git"
-
-COMPATIBLE_HOST = "(i.86|x86_64|powerpc|powerpc64|aarch64|arm).*-linux*"
-
-LIBARGS = "LIB32=${baselib} LIB64=${baselib}"
-LIBHUGETLBFS_ARCH = "${TARGET_ARCH}"
-LIBHUGETLBFS_ARCH_powerpc = "ppc"
-LIBHUGETLBFS_ARCH_powerpc64 = "ppc64"
-EXTRA_OEMAKE = "'ARCH=${LIBHUGETLBFS_ARCH}' 'OPT=${CFLAGS}' 'CC=${CC}' ${LIBARGS} BUILDTYPE=NATIVEONLY V=2"
-PARALLEL_MAKE = ""
-CFLAGS += "-fexpensive-optimizations -frename-registers -fomit-frame-pointer -g0"
-
-export HUGETLB_LDSCRIPT_PATH="${S}/ldscripts"
-
-TARGET_CC_ARCH += "${LDFLAGS}"
-
-#The CUSTOM_LDSCRIPTS doesn't work with the gold linker
-inherit cpan-base
-do_configure() {
- if [ "${@bb.utils.filter('DISTRO_FEATURES', 'ld-is-gold', d)}" ]; then
- sed -i 's/CUSTOM_LDSCRIPTS = yes/CUSTOM_LDSCRIPTS = no/' Makefile
- fi
-}
-
-do_install() {
- oe_runmake PREFIX=${prefix} DESTDIR=${D} \
- INST_TESTSDIR32=${libdir}/libhugetlbfs/tests \
- INST_TESTSDIR64=${libdir}/libhugetlbfs/tests \
- install-tests
-}
-
-
-PACKAGES =+ "${PN}-tests "
-FILES_${PN} += "${libdir}/*.so"
-FILES_${PN}-dev = "${includedir}"
-FILES_${PN}-dbg += "${libdir}/libhugetlbfs/tests/obj32/.debug ${libdir}/libhugetlbfs/tests/obj64/.debug"
-FILES_${PN}-tests += "${libdir}/libhugetlbfs/tests"
-
-INSANE_SKIP_${PN} = "dev-so"
-
-INHIBIT_PACKAGE_STRIP = "1"
-INHIBIT_PACKAGE_DEBUG_SPLIT = "1"