aboutsummaryrefslogtreecommitdiff
path: root/core/recipes-extended/ltp/ltp/0005-kernel-controllers-Link-with-libfts-explicitly-on-mu.patch
diff options
context:
space:
mode:
authorAnders Roxell <anders.roxell@linaro.org>2018-07-05 23:46:03 +0200
committerAnders Roxell <anders.roxell@linaro.org>2018-07-25 12:57:02 +0200
commitd78179134ae0ce2a6ef51f32ca3ff7fe6a977608 (patch)
tree1f71bd2f7cb6851efeeb842e1759c444ef6aa8df /core/recipes-extended/ltp/ltp/0005-kernel-controllers-Link-with-libfts-explicitly-on-mu.patch
parentb9d3b2f81ec9388e5b0ad9a01babc2bd2c6b06e4 (diff)
ltp: bump to release 20180515, for real
The following patches have made it to upstream: * 0001-configure-Fix-default-value-of-without-numa-switch-i.patch * 0001-configure-add-knob-to-control-numa-support.patch * 0003-Add-knob-to-control-tirpc-support.patch * 0010-replace-__BEGIN_DECLS-and-__END_DECLS.patch * 0040-safe_macros-make-is_fuse-return-zero-if-fs_type-is-N.patch These patches have been refreshed in order to apply cleanly and without any fuzz: * 0004-build-Add-option-to-select-libc-implementation.patch * 0008-Check-if-__GLIBC_PREREQ-is-defined-before-using-it.patch * 0021-Define-_GNU_SOURCE-for-MREMAP_MAYMOVE-definition.patch * 0028-rt_sigaction.h-Use-sighandler_t-instead-of-__sighand.patch * 0036-testcases-network-nfsv4-acl-acl1.c-Security-fix-on-s.patch Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org> We ship the open posix test suite already but it isn't compiled. Let's build it and make it ready to use on the device. Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org> Add new patch from OE-core: * 0040-read_all-Define-FNM_EXTMATCH-if-not-already-like-und.patch and one that is yet to be merged upstream: * 0041-cve-2017-5669-shmat-for-0-or-PAGESIZE-with-RND-flag-.patch Add new RDEPENDS: procps. Change a few things in the recipe, chiefly the part where it deals with the packaging of a static library. Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org> Include the following change: 3084ff86 ltp: set -fomit-frame-pointer explicitly for x86-64 Mingli Yu <Mingli.Yu@windriver.com> Also sync the patch that Naresh sent (0041) as it was taken by OE-core. Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org> Change-Id: I6d34dd00f86fd0fe98bff52f3a8d2b7ced96361a Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
Diffstat (limited to 'core/recipes-extended/ltp/ltp/0005-kernel-controllers-Link-with-libfts-explicitly-on-mu.patch')
-rw-r--r--core/recipes-extended/ltp/ltp/0005-kernel-controllers-Link-with-libfts-explicitly-on-mu.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/core/recipes-extended/ltp/ltp/0005-kernel-controllers-Link-with-libfts-explicitly-on-mu.patch b/core/recipes-extended/ltp/ltp/0005-kernel-controllers-Link-with-libfts-explicitly-on-mu.patch
new file mode 100644
index 0000000..b9390e2
--- /dev/null
+++ b/core/recipes-extended/ltp/ltp/0005-kernel-controllers-Link-with-libfts-explicitly-on-mu.patch
@@ -0,0 +1,46 @@
+From 6e3058521b50d91d4b0569c4d491c5af5ff798b2 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 7 Jan 2016 18:22:38 +0000
+Subject: [PATCH 05/32] kernel/controllers: Link with libfts explicitly on musl
+
+musl does not implement fts like glibc and therefore it depends on
+external implementation for all fts APIs
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Pending
+---
+ testcases/kernel/controllers/Makefile.inc | 3 +++
+ testcases/kernel/controllers/cpuset/Makefile.inc | 3 +++
+ 2 files changed, 6 insertions(+)
+
+diff --git a/testcases/kernel/controllers/Makefile.inc b/testcases/kernel/controllers/Makefile.inc
+index b106283..ef5fc0c 100644
+--- a/testcases/kernel/controllers/Makefile.inc
++++ b/testcases/kernel/controllers/Makefile.inc
+@@ -36,6 +36,9 @@ MAKE_DEPS := $(LIB)
+ CPPFLAGS += -I$(abs_srcdir)/../$(LIBDIR)
+
+ LDFLAGS += -L$(abs_builddir)/../$(LIBDIR)
++ifeq ($(LIBC),musl)
++LDLIBS += -lfts
++endif
+
+ INSTALL_TARGETS ?= *.sh
+
+diff --git a/testcases/kernel/controllers/cpuset/Makefile.inc b/testcases/kernel/controllers/cpuset/Makefile.inc
+index 9e002f4..e0fcb9c 100644
+--- a/testcases/kernel/controllers/cpuset/Makefile.inc
++++ b/testcases/kernel/controllers/cpuset/Makefile.inc
+@@ -42,6 +42,9 @@ MAKE_DEPS := $(LIBCONTROLLERS) $(LIBCPUSET)
+ LDFLAGS += -L$(abs_builddir)/$(LIBCPUSET_DIR) -L$(abs_builddir)/$(LIBCONTROLLERS_DIR)
+
+ LDLIBS += -lcpu_set -lcontrollers -lltp
++ifeq ($(LIBC),musl)
++LDLIBS += -lfts
++endif
+
+ INSTALL_TARGETS ?= *.sh
+
+--
+2.7.0
+