aboutsummaryrefslogtreecommitdiff
path: root/core/recipes-extended/ltp/ltp/0028-rt_sigaction.h-Use-sighandler_t-instead-of-__sighand.patch
diff options
context:
space:
mode:
authorAnders Roxell <anders.roxell@linaro.org>2018-07-05 23:46:03 +0200
committerAnders Roxell <anders.roxell@linaro.org>2018-07-25 12:57:02 +0200
commitd78179134ae0ce2a6ef51f32ca3ff7fe6a977608 (patch)
tree1f71bd2f7cb6851efeeb842e1759c444ef6aa8df /core/recipes-extended/ltp/ltp/0028-rt_sigaction.h-Use-sighandler_t-instead-of-__sighand.patch
parentb9d3b2f81ec9388e5b0ad9a01babc2bd2c6b06e4 (diff)
ltp: bump to release 20180515, for real
The following patches have made it to upstream: * 0001-configure-Fix-default-value-of-without-numa-switch-i.patch * 0001-configure-add-knob-to-control-numa-support.patch * 0003-Add-knob-to-control-tirpc-support.patch * 0010-replace-__BEGIN_DECLS-and-__END_DECLS.patch * 0040-safe_macros-make-is_fuse-return-zero-if-fs_type-is-N.patch These patches have been refreshed in order to apply cleanly and without any fuzz: * 0004-build-Add-option-to-select-libc-implementation.patch * 0008-Check-if-__GLIBC_PREREQ-is-defined-before-using-it.patch * 0021-Define-_GNU_SOURCE-for-MREMAP_MAYMOVE-definition.patch * 0028-rt_sigaction.h-Use-sighandler_t-instead-of-__sighand.patch * 0036-testcases-network-nfsv4-acl-acl1.c-Security-fix-on-s.patch Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org> We ship the open posix test suite already but it isn't compiled. Let's build it and make it ready to use on the device. Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org> Add new patch from OE-core: * 0040-read_all-Define-FNM_EXTMATCH-if-not-already-like-und.patch and one that is yet to be merged upstream: * 0041-cve-2017-5669-shmat-for-0-or-PAGESIZE-with-RND-flag-.patch Add new RDEPENDS: procps. Change a few things in the recipe, chiefly the part where it deals with the packaging of a static library. Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org> Include the following change: 3084ff86 ltp: set -fomit-frame-pointer explicitly for x86-64 Mingli Yu <Mingli.Yu@windriver.com> Also sync the patch that Naresh sent (0041) as it was taken by OE-core. Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org> Change-Id: I6d34dd00f86fd0fe98bff52f3a8d2b7ced96361a Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
Diffstat (limited to 'core/recipes-extended/ltp/ltp/0028-rt_sigaction.h-Use-sighandler_t-instead-of-__sighand.patch')
-rw-r--r--core/recipes-extended/ltp/ltp/0028-rt_sigaction.h-Use-sighandler_t-instead-of-__sighand.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/core/recipes-extended/ltp/ltp/0028-rt_sigaction.h-Use-sighandler_t-instead-of-__sighand.patch b/core/recipes-extended/ltp/ltp/0028-rt_sigaction.h-Use-sighandler_t-instead-of-__sighand.patch
new file mode 100644
index 0000000..40ee894
--- /dev/null
+++ b/core/recipes-extended/ltp/ltp/0028-rt_sigaction.h-Use-sighandler_t-instead-of-__sighand.patch
@@ -0,0 +1,48 @@
+From 94557fb7e1293c61145c959b8c5ffecf4a2b1069 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 8 Jan 2016 07:24:44 +0000
+Subject: [PATCH 28/32] rt_sigaction.h: Use sighandler_t instead of
+ __sighandler_t
+
+When _GNU_SOURCE is used then both typedefs are same and using
+sighandler_t makes it work on musl too
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+---
+ include/lapi/rt_sigaction.h | 4 ++--
+ testcases/kernel/syscalls/rt_sigsuspend/Makefile | 3 +++
+ 2 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/include/lapi/rt_sigaction.h b/include/lapi/rt_sigaction.h
+index 18236db..15facda 100644
+--- a/include/lapi/rt_sigaction.h
++++ b/include/lapi/rt_sigaction.h
+@@ -36,12 +36,12 @@
+ #if defined(__mips__)
+ struct kernel_sigaction {
+ unsigned int sa_flags;
+- __sighandler_t k_sa_handler;
++ sighandler_t k_sa_handler;
+ sigset_t sa_mask;
+ };
+ #else
+ struct kernel_sigaction {
+- __sighandler_t k_sa_handler;
++ sighandler_t k_sa_handler;
+ unsigned long sa_flags;
+ void (*sa_restorer) (void);
+ sigset_t sa_mask;
+diff --git a/testcases/kernel/syscalls/rt_sigsuspend/Makefile b/testcases/kernel/syscalls/rt_sigsuspend/Makefile
+index 37bc3a9..2ca7f7c 100644
+--- a/testcases/kernel/syscalls/rt_sigsuspend/Makefile
++++ b/testcases/kernel/syscalls/rt_sigsuspend/Makefile
+@@ -19,4 +19,7 @@
+ top_srcdir ?= ../../../..
+
+ include $(top_srcdir)/include/mk/testcases.mk
++
++CFLAGS += -D_GNU_SOURCE
++
+ include $(top_srcdir)/include/mk/generic_leaf_target.mk