summaryrefslogtreecommitdiff
path: root/meta-linaro
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2017-02-17 09:58:38 +0100
committerKoen Kooi <koen.kooi@linaro.org>2017-02-17 10:00:56 +0100
commitc8328b07618ae60f43465eb8c9eec77572d31032 (patch)
tree6f6cab82460a3012afcd8425b909f0eb0ffb2d87 /meta-linaro
parent531e950e4c3c53408ef70183d3093132696fcb27 (diff)
gator: fix linking, try 2
The previous fix only worked with a partial recompile, this works with a -c cleansstate. Change-Id: Idda2027e2837c6f9897d147fe0f5efb77888be67 Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Diffstat (limited to 'meta-linaro')
-rw-r--r--meta-linaro/recipes-kernel/gator/gator_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-linaro/recipes-kernel/gator/gator_git.bb b/meta-linaro/recipes-kernel/gator/gator_git.bb
index 521fbf9..fc59f9d 100644
--- a/meta-linaro/recipes-kernel/gator/gator_git.bb
+++ b/meta-linaro/recipes-kernel/gator/gator_git.bb
@@ -17,7 +17,7 @@ inherit update-rc.d
# Since this is c++ code we need to both compile and link with CXX
#| PerfSource.o: In function `PerfSource::~PerfSource()':
#| /usr/src/debug/gator/5.22+gitAUTOINC+7ca6004c0b-r0/git/daemon/PerfSource.cpp:128: undefined reference to `operator delete(void*, unsigned long)'
-CC = "${CXX}"
+CCLD = "${CXX}"
EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} ${TARGET_CC_ARCH} -D_DEFAULT_SOURCE -DETCDIR=\"${sysconfdir}\"' \
'LDFLAGS=${LDFLAGS} ${TARGET_CC_ARCH}' 'CROSS_COMPILE=${TARGET_PREFIX}' \
@@ -26,6 +26,8 @@ EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} ${TARGET_CC_ARCH} -D_DEFAULT_SOURCE -DETCDIR=\
do_compile() {
# The regular makefile tries to be 'smart' by hardcoding ABI assumptions, let's use the clean makefile for everything.
cp ${S}/daemon/Makefile_aarch64 ${S}/daemon/Makefile
+ # Allow using a differnt linker than $(CC)
+ sed -i -e 's:$(CC) $(LDFLAGS):$(CCLD) $(LDFLAGS):' ${S}/daemon/common.mk
oe_runmake -C daemon CC='${CC}' CXX='${CXX}'
}