summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis McCollum <travis.mccollum@arm.com>2020-08-04 16:00:39 -0500
committerGitHub <noreply@github.com>2020-08-04 16:00:39 -0500
commitfadd5fd6016dcb31d2a75e623540980ed7606004 (patch)
tree0316a94b59d5b4b2e1566a54f313b73d3f670c43
parent64688686e0489ae7ac95ac3587c6c58b28d06f7c (diff)
parente315de9b21d24b6ddee6a3eb809c116a402dfd9a (diff)
Merge pull request #166 from armPelionEdge/2.1dev-fix
adds the changlog and fixes an error with docker location
-rw-r--r--CHANGELOG.md22
-rw-r--r--recipes-containers/docker/docker_%.bbappend5
2 files changed, 22 insertions, 5 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index d874969..050ff2b 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,21 @@
# Changelog
-
+## Release 2.1.0 - August 2020
+### Added
+Primary feature in this release is the addition of container orchistration
+* [compiler] Switched to [golang 1.14.4](https://github.com/armPelionEdge/meta-pelion-edge/pull/158) compiler from 1.11.1. This includes poky meta upstream [go*.bbclass](classes/) files.
+* [edge-proxy] Added [edge-proxy](https://github.com/armPelionEdge/edge-proxy) tunneling daemon to the [build](https://github.com/armPelionEdge/meta-pelion-edge/pull/160/files#diff-cf2bb0a8acf52dfc5336946e4e85d00a)and subsequent systemD unit and supporting [files](https://github.com/armPelionEdge/meta-pelion-edge/pull/160/files#diff-d168093479202d5365837188cd0ab52f)
+* [devicejs] Moved devicejs default port from [8080 to 8081](https://github.com/armPelionEdge/meta-pelion-edge/pull/160/files#diff-91df9bdf1d7512379b7145418e22a5a2) in support of edge-proxy using 8080 for kubelet
+* [os] modified [/etc/hosts](https://github.com/armPelionEdge/meta-pelion-edge/pull/160/files#diff-2b56f81a8769186caec20129e7038331) creation file to support kubelet communication with edge-proxy using the address gateways.local
+* [os] adds poky's [meta-virtualization](https://git.yoctoproject.org/cgit/cgit.cgi/meta-virtualization/) layer [bblayers](https://github.com/armPelionEdge/meta-pelion-edge/pull/161/files#diff-8eb2e96d599896eef2db53b566b4d701)to bring in docker and containerd programs, as well as kernel optimizations specified in meta-virtualzation to [local.conf](https://github.com/armPelionEdge/meta-pelion-edge/pull/161/files#diff-f427c8a66b8134441c4facaa0aeaa518)).
+* [os] adds [boot flags](https://github.com/armPelionEdge/meta-pelion-edge/pull/161/files#diff-a00df6690f4fb299ba7bae881b745122) to enable cgroups control over memory and cpu utilization.
+* [kubelet] Added [edge-kubelet](https://github.com/armPelionEdge/meta-pelion-edge/pull/161/files), modified to enable container orchistration with Pelion cloud to the main [console-image](https://github.com/armPelionEdge/meta-pelion-edge/pull/161/files#diff-9ed858c519118697208a2af7585cf7ef)
+* [docker] adds docker via rdepends in [edge-kubelet](https://github.com/armPelionEdge/meta-pelion-edge/pull/161/files#diff-a60a51806a69d10af75c2d0a4c752698). Docker's default storage location is moved to [/userdata/Docker](xxxx) to take advantage of /userdata's single (non-overlay) ext4 partition, enabling docker to use the more perforamnt overfs2.
+* [cni] adds contianer networking interfaces [cni](https://github.com/armPelionEdge/meta-pelion-edge/pull/161/files#diff-8d44f3bb16ba9ff316e2e3622366d386) to enable container network communication
+### Bug Fixes
+* general syntax and whitespace changes in bitbake reciepes
+* Fixed the situation where the root password changes after an upgrade by changing the default WIPETHEUSER_PARTITION to 0
+### Known issues
+* While provisioning your gateway, please use `vendor-id=42fa7b48-1a65-43aa-890f-8c704daade54` to unlock the rich node features, such as gateway logs and gateway terminal in the Pelion web portal.
## Release 2.0.0 - 2020-05-18
### Added
* [mbed-edge] Upgraded mbed-edge, also known as edge-core, from 0.8.0 to 0.12.0.
@@ -16,17 +32,13 @@
* [os] Switched init system from SysVinit to SystemD.
* [os] Introduced `gai.conf` to control the sorting order of the addresses resolved by libc library. By default, IPv4 is preferred over IPv6.
* [os] Removed the cronjob, which periodically restarted the gateway services.
-
-
### Bug fixes
* Fixed the situation in which the maestro daemon can run out of the system resources and cause the platform to reboot.
* Fixed the issue of DHCP client being unable to renew the IP address lease.
* Fixed the intermittent failure of remote terminal not connecting to Pelion cloud.
* Fixed the intermittent bug in the maestro daemon, causing it not to restart a monitoring process that exits unexpectedly.
-
### Known issues
* While provisioning your gateway, please use `vendor-id=42fa7b48-1a65-43aa-890f-8c704daade54` to unlock the rich node features, such as gateway logs and gateway terminal in the Pelion web portal.
-
## 1.0.0
### Summary abstract
This is the 1.0 release of the Pelion Edge for Gateways. In general, it is a Yocto metalayer to build an operating system for a gateway that will connect to the Arm Pelion Cloud. Once provisioned with the Pelion Cloud, the gateway can register Bluetooth devices to the cloud, participate in secure update campaigns and be controlled from a mobile application. The first supported platform is the Raspberry PI3b+.
diff --git a/recipes-containers/docker/docker_%.bbappend b/recipes-containers/docker/docker_%.bbappend
index 298167a..fce44b4 100644
--- a/recipes-containers/docker/docker_%.bbappend
+++ b/recipes-containers/docker/docker_%.bbappend
@@ -1,4 +1,9 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
SRC_URI += "file://daemon.json"
+FILES_${PN} += "/etc/docker/daemon.json"
+do_install_append () {
+ install -d ${D}/${sysconfdir}/docker
+ install -m 0644 ${WORKDIR}/daemon.json ${D}/${sysconfdir}/docker/
+} \ No newline at end of file