summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorNic Costa <nic.costa@gmail.com>2019-03-22 09:55:58 -0500
committerNicolas Costa <nic.costa@arm.com>2019-03-22 12:34:07 -0500
commit55bd2fc6493117d76f99e92dc4f70edc92267caa (patch)
treef33b1d86e8872f9e316107aeae7fee9a0d1840e9 /recipes-bsp
parentb3f1fbf2cf8a957e1f6f9dbd89ba21a499e0291e (diff)
clean up some licensing issues
remove unused recipes that we didn't pull in from meta-wigwag and add the required license header to an open source file chageusers.bbclass.
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend11
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bbappend5
2 files changed, 3 insertions, 13 deletions
diff --git a/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend b/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
deleted file mode 100644
index d81b024..0000000
--- a/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
+++ /dev/null
@@ -1,11 +0,0 @@
-RPIFW_DATE = "20190116"
-SRCREV = "c589f89f8df058f8aaac563227fb912a4e1dc88c"
-SRC_URI[md5sum] = "4c72e33343966c27b11d67da45316b33"
-SRC_URI[sha256sum] = "2b9f86b73f1b5b9dedddcc622f2c10cf04259674bccda06ce022f490456a29cf"
-
-RPIFW_SRC_URI = "https://codeload.github.com/raspberrypi/firmware/tar.gz/${SRCREV}"
-RPIFW_S = "${WORKDIR}/firmware-${SRCREV}"
-
-do_unpack() {
- tar -C ${WORKDIR} -xzf ${DL_DIR}/${SRCREV}
-}
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bbappend b/recipes-bsp/bootfiles/rpi-config_git.bbappend
index 838626a..291e247 100644
--- a/recipes-bsp/bootfiles/rpi-config_git.bbappend
+++ b/recipes-bsp/bootfiles/rpi-config_git.bbappend
@@ -1,4 +1,5 @@
-SRCREV = "648ffc470824c43eb0d16c485f4c24816b32cd6f"
+
+COMPATIBLE_MACHINE = "raspberrypi3"
do_deploy_append() {
if [ -z "${MENDER_ARTIFACT_NAME}" ]; then
@@ -17,7 +18,7 @@ do_deploy_append() {
sed -i '/#display_rotate=/ c\display_rotate=${DISPLAY_ROTATE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
fi
- if [ -n "${ENABLE_RPI3_SERIAL_CONSOLE}" ]; then
+ if [ -n "${ENABLE_SERIAL_CONSOLE}" ]; then
echo "" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
echo "dtoverlay=pi3-disable-bt" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
fi