summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorJ. Michael Welsh <mike.welsh@arm.com>2019-01-28 15:54:32 -0600
committerJ. Michael Welsh <mike.welsh@arm.com>2019-01-28 16:39:38 -0600
commitcfbff0c8b5cdafe6b96c6853bbc79678ab9a8344 (patch)
treef3342357c4633a7d27e410a00dcfada83bfc06ed /recipes-bsp
parenta75a60e052c0a0f0c20b429f2e93cb557c329f6e (diff)
Added in as much of the WigWag Meta will build.
Signed-off-by: J. Michael Welsh <mike.welsh@arm.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend11
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bbappend24
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend b/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
new file mode 100644
index 0000000..d81b024
--- /dev/null
+++ b/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
@@ -0,0 +1,11 @@
+RPIFW_DATE = "20190116"
+SRCREV = "c589f89f8df058f8aaac563227fb912a4e1dc88c"
+SRC_URI[md5sum] = "4c72e33343966c27b11d67da45316b33"
+SRC_URI[sha256sum] = "2b9f86b73f1b5b9dedddcc622f2c10cf04259674bccda06ce022f490456a29cf"
+
+RPIFW_SRC_URI = "https://codeload.github.com/raspberrypi/firmware/tar.gz/${SRCREV}"
+RPIFW_S = "${WORKDIR}/firmware-${SRCREV}"
+
+do_unpack() {
+ tar -C ${WORKDIR} -xzf ${DL_DIR}/${SRCREV}
+}
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bbappend b/recipes-bsp/bootfiles/rpi-config_git.bbappend
new file mode 100644
index 0000000..3faeeaa
--- /dev/null
+++ b/recipes-bsp/bootfiles/rpi-config_git.bbappend
@@ -0,0 +1,24 @@
+SRCREV = "648ffc470824c43eb0d16c485f4c24816b32cd6f"
+
+do_deploy_append() {
+ if [ -z "${MENDER_ARTIFACT_NAME}" ]; then
+ if [ -n "${KERNEL_IMAGETYPE}" ]; then
+ sed -i '/#kernel=/ c\kernel=${KERNEL_IMAGETYPE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ fi
+ fi
+
+ if [ -n "${DISABLE_SPLASH}" ]; then
+ sed -i '/#disable_splash=/ c\disable_splash=${DISABLE_SPLASH}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ fi
+
+ # HDMI display rotation
+ # 0 = none, 1 = 90cw, 2 = 180cw, 3 = 270cw, 0x10000 = hflip, 0x20000 = vflip
+ if [ -n "${DISPLAY_ROTATE}" ]; then
+ sed -i '/#display_rotate=/ c\display_rotate=${DISPLAY_ROTATE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ fi
+
+ if [ -n "${ENABLE_RPI3_SERIAL_CONSOLE}" ]; then
+ echo "" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=pi3-disable-bt" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ fi
+}