summaryrefslogtreecommitdiff
path: root/recipes-bsp/bootfiles/rpi-config_git.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/bootfiles/rpi-config_git.bbappend')
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bbappend24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bbappend b/recipes-bsp/bootfiles/rpi-config_git.bbappend
new file mode 100644
index 0000000..3faeeaa
--- /dev/null
+++ b/recipes-bsp/bootfiles/rpi-config_git.bbappend
@@ -0,0 +1,24 @@
+SRCREV = "648ffc470824c43eb0d16c485f4c24816b32cd6f"
+
+do_deploy_append() {
+ if [ -z "${MENDER_ARTIFACT_NAME}" ]; then
+ if [ -n "${KERNEL_IMAGETYPE}" ]; then
+ sed -i '/#kernel=/ c\kernel=${KERNEL_IMAGETYPE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ fi
+ fi
+
+ if [ -n "${DISABLE_SPLASH}" ]; then
+ sed -i '/#disable_splash=/ c\disable_splash=${DISABLE_SPLASH}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ fi
+
+ # HDMI display rotation
+ # 0 = none, 1 = 90cw, 2 = 180cw, 3 = 270cw, 0x10000 = hflip, 0x20000 = vflip
+ if [ -n "${DISPLAY_ROTATE}" ]; then
+ sed -i '/#display_rotate=/ c\display_rotate=${DISPLAY_ROTATE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ fi
+
+ if [ -n "${ENABLE_RPI3_SERIAL_CONSOLE}" ]; then
+ echo "" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=pi3-disable-bt" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ fi
+}