aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Botcazou <ebotcazou@adacore.com>2012-10-23 22:57:43 +0000
committerEric Botcazou <ebotcazou@adacore.com>2012-10-23 22:57:43 +0000
commitcb8ff62437092dcbfdf70b2dd1360ba037444a4d (patch)
tree36ccc334c30fd823107a6719f4510385a9b3ca6e /configure.ac
parentb18b0c295250ada2934834ecac83af24040d7307 (diff)
PR bootstrap/54820
* configure.ac (have_static_libs): Force 'no' for GCC version < 4.5. * configure: Regenerate. git-svn-id: https://gcc.gnu.org/svn/gcc/trunk@192748 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 958eadd5e78..c6665a1f33a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1190,7 +1190,11 @@ if test "$GCC" = yes; then
LDFLAGS="$LDFLAGS -static-libstdc++ -static-libgcc"
AC_MSG_CHECKING([whether g++ accepts -static-libstdc++ -static-libgcc])
AC_LANG_PUSH(C++)
- AC_LINK_IFELSE([int main() {}],
+ AC_LINK_IFELSE([
+#if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
+#error -static-libstdc++ not implemented
+#endif
+int main() {}],
[AC_MSG_RESULT([yes]); have_static_libs=yes],
[AC_MSG_RESULT([no])])
AC_LANG_POP(C++)