aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMohan Embar <gnustuff@thisiscool.com>2003-10-06 03:40:08 +0000
committerMohan Embar <gnustuff@thisiscool.com>2003-10-06 03:40:08 +0000
commitfe440a77b61966e26b590ecd0f5fd53402c6019a (patch)
tree796d96198d1c4a8e3116eba1800ed180d7f4ea09 /configure.in
parent616ec7976d1a39eb1516a2b0a0505a5418c722bf (diff)
* configure.in: Allow explicit specification of CFLAGS_FOR_BUILD.
* configure: Rebuilt * Makefile.tpl: Use CFLAGS_FOR_BUILD computed by configure * Makefile.in: Rebuilt git-svn-id: https://gcc.gnu.org/svn/gcc/trunk@72130 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3d30f62b792..1ab21a8345f 100644
--- a/configure.in
+++ b/configure.in
@@ -1919,6 +1919,10 @@ case " $target_configdirs " in
;;
esac
+# Allow the user to override the flags for
+# our build compiler if desired.
+CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${CFLAGS}}
+
# On Canadian crosses, we'll be searching the right directories for
# the previously-installed cross compiler, so don't bother to add
# flags for directories within the install tree of the compiler
@@ -2060,6 +2064,7 @@ NCN_STRICT_CHECK_TOOL(OBJDUMP, objdump)
AC_SUBST(CC)
AC_SUBST(CXX)
AC_SUBST(CFLAGS)
+AC_SUBST(CFLAGS_FOR_BUILD)
AC_SUBST(CXXFLAGS)
AC_SUBST(DEFAULT_YACC)
AC_SUBST(DEFAULT_LEX)