aboutsummaryrefslogtreecommitdiff
path: root/fixincludes/configure.ac
diff options
context:
space:
mode:
authorKaveh Ghazi <ghazi@caip.rutgers.edu>2005-07-16 14:17:51 +0000
committerKaveh Ghazi <ghazi@caip.rutgers.edu>2005-07-16 14:17:51 +0000
commit703e6fa7a42c7630f73900c3016af5030d85859d (patch)
tree5b1768cf44367ca62e49b6efd0e18557e36b689c /fixincludes/configure.ac
parent4e8525f9a8b78e5ddf79ae630307353326b67716 (diff)
* Makefile.in (WARN_CFLAGS): New.
(.c.o): Add $(WARN_CFLAGS). * aclocal.m4: Include ../config/warnings.m4. * configure.ac: Invoke ACX_PROG_CC_WARNING_OPTS, ACX_PROG_CC_WARNING_ALMOST_PEDANTIC and ACX_PROG_CC_WARNINGS_ARE_ERRORS. * fixopts.c (initialize_opts): Fix old-style definintion. * configure: Regenerate. git-svn-id: https://gcc.gnu.org/svn/gcc/trunk@102088 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'fixincludes/configure.ac')
-rw-r--r--fixincludes/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/fixincludes/configure.ac b/fixincludes/configure.ac
index 46296049f31..04305fe63b7 100644
--- a/fixincludes/configure.ac
+++ b/fixincludes/configure.ac
@@ -6,6 +6,18 @@ AC_CONFIG_AUX_DIR(..)
AC_CANONICAL_SYSTEM
AC_PROG_CC
+# Figure out what compiler warnings we can enable.
+# See config/warnings.m4 for details.
+
+ACX_PROG_CC_WARNING_OPTS([-W -Wall -Wwrite-strings -Wstrict-prototypes \
+ -Wmissing-prototypes -Wold-style-definition \
+ -Wmissing-format-attribute])
+ACX_PROG_CC_WARNING_ALMOST_PEDANTIC([-Wno-long-long])
+
+# Only enable with --enable-werror-always until existing warnings are
+# corrected.
+ACX_PROG_CC_WARNINGS_ARE_ERRORS([manual])
+
# Determine the noncanonical target name, for directory use.
ACX_NONCANONICAL_TARGET