aboutsummaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorDiego Novillo <dnovillo@google.com>2012-05-31 17:25:41 +0000
committerDiego Novillo <dnovillo@google.com>2012-05-31 17:25:41 +0000
commit0808956693b6b62e4a63a672b77149a683c8c662 (patch)
treee88d1126cb49f12ae276830176979bf2a5075453 /gcc/configure.ac
parent73cfeaf45bc0da07875b63d3a647305de055b93c (diff)
Fix compilation of build/*.o when using C++.
Found this while testing the C++ conversion for vec.[ch] on the cxx-conversion branch. We do not build the build/*.o files with g++, so I was getting lots of syntax errors while compiling build/vec.o. 2012-05-31 Diego Novillo <dnovillo@google.com> * configure.ac (CXX_FOR_BUILD): Define and substitute. (BUILD_CXXFLAGS): Define and substitute. * Makefile.in (BUILD_CXXFLAGS): Define. (CXX_FOR_BUILD): Define. (COMPILER_FOR_BUILD): Set to CXX_FOR_BUILD if building with C++. (LINKER_FOR_BUILD): Likewise. (BUILD_COMPILERFLAGS): Set to BUILD_CXXFLAGS if building with C++. (BUILD_LINKERFLAGS): Likewise. * configure: Regenerate. git-svn-id: https://gcc.gnu.org/svn/gcc/trunk@188069 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index a3a40389a3c..22dab55a24a 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -1848,7 +1848,9 @@ AC_SUBST(inhibit_libc)
# These are the normal (build=host) settings:
CC_FOR_BUILD='$(CC)' AC_SUBST(CC_FOR_BUILD)
+CXX_FOR_BUILD='$(CXX)' AC_SUBST(CXX_FOR_BUILD)
BUILD_CFLAGS='$(ALL_CFLAGS)' AC_SUBST(BUILD_CFLAGS)
+BUILD_CXXFLAGS='$(ALL_CXXFLAGS)' AC_SUBST(BUILD_CXXFLAGS)
BUILD_LDFLAGS='$(LDFLAGS)' AC_SUBST(BUILD_LDFLAGS)
STMP_FIXINC=stmp-fixinc AC_SUBST(STMP_FIXINC)