aboutsummaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorDavid Edelsohn <dje.gcc@gmail.com>2013-02-01 20:26:24 +0000
committerDavid Edelsohn <dje.gcc@gmail.com>2013-02-01 20:26:24 +0000
commit4b27c1fe5e1eab26d5bb9f9c7a61c5ebe897ad14 (patch)
tree30472f84083cf675f186689b2add871ca6d548f8 /gcc/configure.ac
parent7d26285a7ec2d882a053a7dcbd7b6af7b89d91a4 (diff)
PR target/54601
libgcc/ * config.host (powerpc-ibm-aix[56789]): Add t-aix-cxa to tmake_file. Add crtcxa to extra_parts. * config/rs6000/exit.h: New file. * config/rs6000/cxa_atexit.c: New file. * config/rs6000/cxa_finalize.c: New file. * config/rs6000/crtcxa.c: New file. * config/rs6000/t-aix-cxa: New file. * config/rs6000/libgcc-aix-cxa.ver: New file. gcc/ * configure.ac (cxa_atexit): Add AIX. * configure: Regenerate. * config/rs6000/aix61.h (STARTFILE_SPEC): Add crtcxa.o. git-svn-id: https://gcc.gnu.org/svn/gcc/trunk@195675 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 9ae56048905..811c296cb81 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -1455,6 +1455,9 @@ if test x$enable___cxa_atexit = xyes || \
*-*-mingw32*)
use_cxa_atexit=yes
;;
+ powerpc-ibm-aix*)
+ use_cxa_atexit=yes
+ ;;
*)
AC_CHECK_FUNC(__cxa_atexit,[use_cxa_atexit=yes],
[echo "__cxa_atexit can't be enabled on this target"])