aboutsummaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorDavid Edelsohn <dje.gcc@gmail.com>2013-01-10 16:00:44 +0000
committerDavid Edelsohn <dje.gcc@gmail.com>2013-01-10 16:00:44 +0000
commit6bfc38c9836e1ff7632a71b4cef1b06e603dc1ad (patch)
treeba4adc8aa46ce7bc664e895801bd212e4545ad46 /gcc/configure.ac
parentd607908f981e443477a1c7ac2d2147c91c6a2ef6 (diff)
* configure.ac (HAVE_AS_TLS): Add check for powerpc-ibm-aix.
* configure: Regenerate. git-svn-id: https://gcc.gnu.org/svn/gcc/trunk@195088 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 447a0ca3056..7cbc705dd1f 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -3010,6 +3010,24 @@ foo: .long 25
tls_first_minor=20
tls_as_opt='--fatal-warnings'
;;
+ powerpc-ibm-aix*)
+ conftest_s='
+ .extern __get_tpointer
+ .toc
+LC..1:
+ .tc a[TC],a[TL]@le
+ .csect .text[PR]
+.tlstest:
+ lwz 9,LC..1(2)
+ bla __get_tpointer
+ lwzx 3,9,3
+ .globl a
+ .csect a[TL],4
+a:
+ .space 4'
+ tls_first_major=0
+ tls_first_minor=0
+ ;;
powerpc-*-*)
conftest_s='
.section ".tdata","awT",@progbits