aboutsummaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorAndrew Pinski <apinski@cavium.com>2012-11-10 18:32:23 +0000
committerAndrew Pinski <apinski@cavium.com>2012-11-10 18:32:23 +0000
commit7067573430dfb0b1560977128c9d7b92fc1bbf02 (patch)
tree633f3194410ca390abbc14cc33b7d5be02a91de1 /gcc/configure.ac
parent24f47eadbf5de0e788b693f1cc31c2f911e4a188 (diff)
2012-11-10 Andrew Pinski <apinski@cavium.com>
PR bootstrap/55202 * configure.ac: Set PLUGIN_LD_SUFFIX to just "ld" if it was "ld-new" or "collect-ld". * configure: Regenerate. git-svn-id: https://gcc.gnu.org/svn/gcc/trunk@193393 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index fbda2cc0207..e0e12c0c4e0 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -2003,6 +2003,12 @@ fi])
ORIGINAL_PLUGIN_LD_FOR_TARGET=$gcc_cv_ld
PLUGIN_LD_SUFFIX=`basename $gcc_cv_ld | sed -e "s,$target_alias-,,"`
+# if the PLUGIN_LD is set ld-new, just have it as ld
+# as that is the installed named.
+if test x$PLUGIN_LD_SUFFIX == xld-new \
+ || test x$PLUGIN_LD_SUFFIX == xcollect-ld ; then
+ PLUGIN_LD_SUFFIX=ld
+fi
AC_ARG_WITH(plugin-ld,
[AS_HELP_STRING([[--with-plugin-ld=[ARG]]], [specify the plugin linker])],
[if test x"$withval" != x; then