aboutsummaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorJakub Jelinek <jakub@redhat.com>2012-09-13 16:30:17 +0000
committerJakub Jelinek <jakub@redhat.com>2012-09-13 16:30:17 +0000
commitaa5ddd55e21b235407ba8abe01db391620714ddb (patch)
treea97fdaa775139296ea4ae1f6e7c2a5559a26295f /gcc/configure.ac
parent9c9d8dc149e84ec7a9fcd2ea013612d70351ffef (diff)
* configure.ac (CXXFLAGS): Remove -O2 when not bootstrapping.
* configure: Regenerated. git-svn-id: https://gcc.gnu.org/svn/gcc/trunk@191267 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 9f200c7a991..5a260228973 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -296,9 +296,11 @@ AC_SUBST(OUTPUT_OPTION)
# optimizations to be activated explicitly by the toplevel.
case "$CC" in
*/prev-gcc/xgcc*) ;;
- *) CFLAGS=`echo $CFLAGS | sed "s/-O[[s0-9]]* *//" ` ;;
+ *) CFLAGS=`echo $CFLAGS | sed "s/-O[[s0-9]]* *//" `
+ CXXFLAGS=`echo $CXXFLAGS | sed "s/-O[[s0-9]]* *//" ` ;;
esac
AC_SUBST(CFLAGS)
+AC_SUBST(CXXFLAGS)
# Determine PICFLAG for target gnatlib.
GCC_PICFLAG_FOR_TARGET