aboutsummaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorAlan Modra <amodra@gmail.com>2012-10-18 23:02:25 +0000
committerAlan Modra <amodra@gmail.com>2012-10-18 23:02:25 +0000
commitd690a0c68ae866263365447d09e8498dfbd10fb3 (patch)
tree806b6c620befad6e9a7bbac69abb13ff01296cfc /gcc/configure.ac
parent2a7b3c0a7832785f7d14d7b4e8e18fa036ec0995 (diff)
* configure.ac (HAVE_LD_NO_DOT_SYMS): Set if using gold.
(HAVE_LD_LARGE_TOC): Likewise. * configure: Regenerate. git-svn-id: https://gcc.gnu.org/svn/gcc/trunk@192593 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index b6c049b022b..17e1d86e349 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -4394,7 +4394,9 @@ case "$target:$tm_file" in
AC_CACHE_CHECK(linker support for omitting dot symbols,
gcc_cv_ld_no_dot_syms,
[gcc_cv_ld_no_dot_syms=no
- if test $in_tree_ld = yes ; then
+ if test x"$ld_is_gold" = xyes; then
+ gcc_cv_ld_no_dot_syms=yes
+ elif test $in_tree_ld = yes ; then
if test "$gcc_cv_gld_major_version" -eq 2 -a "$gcc_cv_gld_minor_version" -ge 16 -o "$gcc_cv_gld_major_version" -gt 2; then
gcc_cv_ld_no_dot_syms=yes
fi
@@ -4431,7 +4433,9 @@ EOF
AC_CACHE_CHECK(linker large toc support,
gcc_cv_ld_large_toc,
[gcc_cv_ld_large_toc=no
- if test $in_tree_ld = yes ; then
+ if test x"$ld_is_gold" = xyes; then
+ gcc_cv_ld_large_toc=yes
+ elif test $in_tree_ld = yes ; then
if test "$gcc_cv_gld_major_version" -eq 2 -a "$gcc_cv_gld_minor_version" -ge 21 -o "$gcc_cv_gld_major_version" -gt 2; then
gcc_cv_ld_large_toc=yes
fi