aboutsummaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorDiego Novillo <dnovillo@google.com>2013-01-24 15:13:46 +0000
committerDiego Novillo <dnovillo@google.com>2013-01-24 15:13:46 +0000
commitf320678e8b7d3542781abe44d8d07330b2a7f760 (patch)
tree34d4eb3cfee54bbc5c75bfb073ac74fea18fdc6d /gcc/configure.ac
parent20649d66487117b78418afb1c6cc14b3a8237e9d (diff)
Remove zone allocator.
This patch removes the GC zone allocator. It is not used and it produces several regressions in the testsuite. Furthermore, it complicates things for the plan to implement manual GC markers (http://gcc.gnu.org/wiki/cxx-conversion/gc-alternatives#Do_GC_marking_manually). Tested on x86_64 with standard checking, --enable-checking=gc and --enable-checking=release. git-svn-id: https://gcc.gnu.org/svn/gcc/trunk@195426 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac24
1 files changed, 6 insertions, 18 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 3703a20b075..24568f1371f 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -4797,26 +4797,14 @@ if test x$gcc_cv_target_dl_iterate_phdr = xyes; then
fi
AC_MSG_RESULT($gcc_cv_target_dl_iterate_phdr)
-# Find out what GC implementation we want, or may, use.
+# We no longer support different GC mechanisms. Emit an error if
+# the user configures with --with-gc.
AC_ARG_WITH(gc,
[AS_HELP_STRING([--with-gc={page,zone}],
- [choose the garbage collection mechanism to use
- with the compiler])],
-[case "$withval" in
- page)
- GGC=ggc-$withval
- ;;
- zone)
- GGC=ggc-$withval
- AC_DEFINE(GGC_ZONE, 1, [Define if the zone collector is in use])
- ;;
- *)
- AC_MSG_ERROR([$withval is an invalid option to --with-gc])
- ;;
-esac],
-[GGC=ggc-page])
-AC_SUBST(GGC)
-echo "Using $GGC for garbage collection."
+ [this option is not supported anymore. It used to choose
+ the garbage collection mechanism to use with the compiler])],
+[AC_MSG_ERROR([Configure option --with-gc is only supported up to GCC 4.7.x])],
+[])
# Libraries to use on the host. This will normally be set by the top
# level Makefile. Here we simply capture the value for our Makefile.