aboutsummaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorRichard Sandiford <richard@codesourcery.com>2007-09-14 14:50:26 +0000
committerRichard Sandiford <richard@codesourcery.com>2007-09-14 14:50:26 +0000
commit12885752e46e80ba84d1ae78dacc50ed0cc1ad50 (patch)
tree5fe65fdbed9bdd4d82e32814abcd604d2cdc1549 /gcc/configure.ac
parent80c1b7b91787c6e8b0a11518f614ec49649fdb49 (diff)
* configure.ac (mips*-sde-elf*): New stanza. Add target-libiberty
to $skipdirs and only disable gprof for newlib. Use the normal mips*-elf* handling in other respects. * configure: Regnerate. gcc/ 2007-xx-xx Nigel Stephens <nigel@mips.com> David Ung <davidu@mips.com> Thiemo Seufer <ths@mips.com> Richard Sandiford <richard@codesourcery.com> * config.gcc (mips*-sde-elf*): Add support for the SDE C libraries. * configure.ac: Add a mipssde threading type. * configure: Regenerate. * config/mips/sdemtk.h: New file. * config/mips/t-sdemtk: Likewise. * config/mips/sdemtk.opt: Likewise. * gthr-mipssde.h: Likewise. * config/mips/sde.h (FUNCTION_PROFILER): Move to config/mips/sdemtk.h. * config/mips/mips.h (MIPS_SAVE_REG_FOR_PROFILING_P): New macro. (MIPS_ICACHE_SYNC): New macro, split from ... * config/mips/mips.md (clear_cache): ...here. * config/mips/mips.c (mips_save_reg_p): Check MIPS_SAVE_REG_FOR_PROFILING_P on profiled functions. (build_mips16_function_stub): Use targetm.strip_name_encoding. (build_mips16_call_stub): Likewise. libstdc++-v3/ 2007-xx-xx Thiemo Seufer <ths@mips.com> * crossconfig.m4 (mips*-sde-elf*): New stanza. * configure: Regenerate. git-svn-id: https://gcc.gnu.org/svn/gcc/trunk@128495 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index fae5ec0d9f3..9627d36e363 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -1342,7 +1342,7 @@ case ${enable_threads} in
target_thread_file='single'
;;
aix | dce | gnat | irix | posix | posix95 | rtems | \
- single | solaris | vxworks | win32 )
+ single | solaris | vxworks | win32 | mipssde)
target_thread_file=${enable_threads}
;;
*)