aboutsummaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorH.J. Lu <hongjiu.lu@intel.com>2008-07-12 13:34:50 +0000
committerH.J. Lu <hongjiu.lu@intel.com>2008-07-12 13:34:50 +0000
commitf344eac659527c9c3cee9e265f415fd3e501d7ed (patch)
tree585a80903632783b4fe88ff61dc9a5f20bb7398a /gcc/configure.ac
parent056cc0c140859618b02af0a5583c4bd47fc314fa (diff)
Merged with trunk at revision 137737.
git-svn-id: https://gcc.gnu.org/svn/gcc/branches/stack@137738 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index dd62e956e65..d5244bd3800 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -323,8 +323,8 @@ AC_CHECK_TYPES([__int64], [AC_CHECK_SIZEOF(__int64)])
# So, we only use -pedantic if we can disable those warnings.
ACX_PROG_CC_WARNING_OPTS([-W -Wall -Wwrite-strings -Wstrict-prototypes \
- -Wmissing-prototypes -Wcast-qual -Wc++-compat], [loose_warn])
-ACX_PROG_CC_WARNING_OPTS([-Wold-style-definition \
+ -Wmissing-prototypes -Wcast-qual], [loose_warn])
+ACX_PROG_CC_WARNING_OPTS([-Wold-style-definition -Wc++-compat \
-Wmissing-format-attribute], [strict_warn])
ACX_PROG_CC_WARNING_ALMOST_PEDANTIC([-Wno-long-long -Wno-variadic-macros \
-Wno-overlength-strings], [strict_warn])