aboutsummaryrefslogtreecommitdiff
path: root/intl/configure.ac
diff options
context:
space:
mode:
authorno-author <no-author@gcc.gnu.org>2004-03-02 18:44:48 +0000
committerno-author <no-author@gcc.gnu.org>2004-03-02 18:44:48 +0000
commite2e520b3f8f6e7f9f71bea37ffe2cecfa431a886 (patch)
tree8fe8150a6642b5a88e37f731a87d641f1740642e /intl/configure.ac
parent583327a5f48e31d05d5840e03dcae28e1c66cb22 (diff)
This commit was manufactured by cvs2svn to create branch
'tree-ssa-20020619-branch'. git-svn-id: https://gcc.gnu.org/svn/gcc/branches/tree-ssa-20020619-branch@78771 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'intl/configure.ac')
-rw-r--r--intl/configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/intl/configure.ac b/intl/configure.ac
new file mode 100644
index 00000000000..0f54336ba86
--- /dev/null
+++ b/intl/configure.ac
@@ -0,0 +1,33 @@
+AC_PREREQ(2.57)
+AC_INIT
+AC_CONFIG_SRCDIR(gettext.c)
+AC_CONFIG_HEADER(config.h)
+AM_GNU_GETTEXT_VERSION(0.12.1)
+AM_GNU_GETTEXT
+
+# This replaces the extensive use of DEFS in the original Makefile.in.
+AC_DEFINE(IN_LIBINTL, 1, [Define because this is libintl.])
+AC_DEFINE(IN_LIBRARY, 1, [Define because this is a library.])
+AC_DEFINE(DEPENDS_ON_LIBICONV, 1, [Define because we depend on libiconv.])
+AC_DEFINE(ENABLE_RELOCATABLE, 1, [Define to enable relocation.])
+AC_DEFINE(NO_XMALLOC, 1, [Define if there is no xmalloc.])
+AC_DEFINE(set_relocation_prefix, libintl_set_relocation_prefix,
+[Define this entry point correctly.])
+AC_DEFINE(relocate, libintl_relocate,
+[Define this entry point correctly.])
+
+# Additional info for config.intl.
+AC_SUBST(LIBINTL_DEP)
+AC_SUBST(INCINTL)
+
+LIBINTL_DEP=
+INCINTL=
+case $USE_INCLUDED_LIBINTL in
+ yes)
+ LIBINTL_DEP='${top_builddir}/intl/libintl.a'
+ INCINTL='-I${top_builddir}/intl'
+ ;;
+esac
+
+AC_CONFIG_FILES(Makefile config.intl)
+AC_OUTPUT