aboutsummaryrefslogtreecommitdiff
path: root/libjava/configure.ac
diff options
context:
space:
mode:
authorRalf Wildenhues <Ralf.Wildenhues@gmx.de>2009-11-02 18:52:08 +0000
committerRalf Wildenhues <Ralf.Wildenhues@gmx.de>2009-11-02 18:52:08 +0000
commit392eb6e82cb7c0f2dcb5ca47b08aa6f263e0236d (patch)
treea3ff4a65da69ce5debef506bae875850070a3748 /libjava/configure.ac
parentcc2b6f57fa9ce50301096914d132186eb0ccc32b (diff)
Work with defaulted $prefix (NONE) in libjava.
libjava/: PR bootstrap/38867 * configure.ac (expanded_prefix): New variable, set to the default prefix if none was passed on the command line. * configure: Regenerate. git-svn-id: https://gcc.gnu.org/svn/gcc/trunk@153820 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/configure.ac')
-rw-r--r--libjava/configure.ac15
1 files changed, 10 insertions, 5 deletions
diff --git a/libjava/configure.ac b/libjava/configure.ac
index be143c5b833..b2037d28152 100644
--- a/libjava/configure.ac
+++ b/libjava/configure.ac
@@ -366,7 +366,12 @@ AM_CONDITIONAL(X_AWT, test "$use_x_awt" = yes)
AC_DEFINE_UNQUOTED(AWT_TOOLKIT, "$TOOLKIT", [Name of default AWT toolkit])
-AC_DEFINE_UNQUOTED(LIBGCJ_PREFIX, "$prefix", [Installation prefix])
+expanded_prefix=$prefix
+if test "X$prefix" = XNONE; then
+ expanded_prefix=${ac_default_prefix}
+fi
+
+AC_DEFINE_UNQUOTED(LIBGCJ_PREFIX, "$expanded_prefix", [Installation prefix])
# Create standard.omit based on decisions we just made.
cp $srcdir/standard.omit.in standard.omit
@@ -1437,7 +1442,7 @@ if test ! -f gnu/classpath/Configuration.java; then
test -d gnu || mkdir gnu
test -d gnu/classpath || mkdir gnu/classpath
# Note that it is not crucial that all the values here be correct.
- sed -e "s,@prefix@,$prefix," \
+ sed -e "s,@prefix@,$expanded_prefix," \
-e "s,@VERSION@,$VERSION," \
-e "s,@LIBDEBUG@,false," \
-e "s,@INIT_LOAD_LIBRARY@,false," \
@@ -1775,10 +1780,10 @@ then
# Needed for installing Python modules during make install.
python_mod_dir="\${prefix}/share/python"
# Needed for substituting into aot-compile*
- python_mod_dir_expanded="${prefix}/share/python"
+ python_mod_dir_expanded="${expanded_prefix}/share/python"
else
python_mod_dir="\${prefix}${with_python_dir}"
- python_mod_dir_expanded="${prefix}${with_python_dir}"
+ python_mod_dir_expanded="${expanded_prefix}${with_python_dir}"
fi
AC_MSG_RESULT(Python modules dir: ${python_mod_dir_expanded});
AC_SUBST(python_mod_dir)
@@ -1956,7 +1961,7 @@ then
LIBDIR=$libdir
if test "x${exec_prefix}" = "xNONE"
then
- lib_exec_prefix=$prefix
+ lib_exec_prefix=$expanded_prefix
else
lib_exec_prefix=$exec_prefix
fi