aboutsummaryrefslogtreecommitdiff
path: root/libjava/configure.ac
diff options
context:
space:
mode:
authorMatthias Klose <doko@ubuntu.com>2009-10-22 09:25:51 +0000
committerMatthias Klose <doko@ubuntu.com>2009-10-22 09:25:51 +0000
commit82b22c88e810873176113669f2d29fe031d55b29 (patch)
tree977fa9f0d41e9d75d58f4b2ceb7f5611ec406453 /libjava/configure.ac
parent3ef4da6120b88efb9c3d83dd652f6c838f105053 (diff)
gcc/
2009-10-22 Matthias Klose <doko@ubuntu.com> * doc/install.texi: Document --enable-browser-plugin. libjava/ 2009-10-22 Matthias Klose <doko@ubuntu.com> * configure.ac: Rename --enable-plugin to --enable-browser-plugin, pass --{en,dis}able-plugin to the classpath configure. * configure: Regenerate. git-svn-id: https://gcc.gnu.org/svn/gcc/trunk@153448 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/configure.ac')
-rw-r--r--libjava/configure.ac16
1 files changed, 9 insertions, 7 deletions
diff --git a/libjava/configure.ac b/libjava/configure.ac
index bfd33fd5154..be143c5b833 100644
--- a/libjava/configure.ac
+++ b/libjava/configure.ac
@@ -55,15 +55,15 @@ AC_ARG_ENABLE(version-specific-runtime-libs,
[version_specific_libs=no]
)
-AC_ARG_ENABLE(plugin,
- AS_HELP_STRING([--enable-plugin],
+AC_ARG_ENABLE(browser-plugin,
+ AS_HELP_STRING([--enable-browser-plugin],
[build gcjwebplugin web browser plugin]),
[case "$enableval" in
- yes) plugin_enabled=yes ;;
- no) plugin_enabled=no ;;
- *) AC_MSG_ERROR([Unknown argument to enable/disable plugin]);;
+ yes) browser_plugin_enabled=yes ;;
+ no) browser_plugin_enabled=no ;;
+ *) AC_MSG_ERROR([Unknown argument to enable/disable browser plugin]);;
esac],
- [plugin_enabled=no]
+ [browser_plugin_enabled=no]
)
AC_ARG_ENABLE(gconf-peer,
@@ -491,8 +491,10 @@ ac_configure_args="$ac_configure_args --disable-core-jni"
dnl FIXME?
ac_configure_args="$ac_configure_args --disable-examples"
ac_configure_args="$ac_configure_args --with-glibj=build"
-if test "$plugin_enabled" != yes; then
+if test "$browser_plugin_enabled" != yes; then
ac_configure_args="$ac_configure_args --disable-plugin"
+else
+ ac_configure_args="$ac_configure_args --enable-plugin"
fi
if test "$gconf_enabled" != yes; then
ac_configure_args="$ac_configure_args --disable-gconf-peer"