aboutsummaryrefslogtreecommitdiff
path: root/libstdc++-v3/configure.ac
diff options
context:
space:
mode:
authorSteve Ellcey <sellcey@mips.com>2013-10-31 17:12:35 +0000
committerSteve Ellcey <sellcey@mips.com>2013-10-31 17:12:35 +0000
commit08c6ed7600ad5d5b5a3a087b18c3dd38d358f82a (patch)
tree6b578de9dd58011acc05d5406f069f861fc44122 /libstdc++-v3/configure.ac
parent2329ab07d0ad25fb65b7e84d36830910ea5d488a (diff)
2013-10-31 Steve Ellcey <sellcey@mips.com>
* configure.ac: Add header checks for fenv.h and complex.h. * configure: Regenerate. git-svn-id: https://gcc.gnu.org/svn/gcc/trunk@204270 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/configure.ac')
-rw-r--r--libstdc++-v3/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/libstdc++-v3/configure.ac b/libstdc++-v3/configure.ac
index dd13b011f97..22fc840f68b 100644
--- a/libstdc++-v3/configure.ac
+++ b/libstdc++-v3/configure.ac
@@ -195,6 +195,12 @@ GLIBCXX_CHECK_S_ISREG_OR_S_IFREG
AC_CHECK_HEADERS(sys/uio.h)
GLIBCXX_CHECK_WRITEV
+# Check for fenv.h and complex.h before GLIBCXX_CHECK_C99_TR1
+# so that the check is done with the C compiler (not C++).
+# Checking with C++ can break a canadian cross build if either
+# file does not exist in C but does in C++.
+AC_CHECK_HEADERS(fenv.h complex.h)
+
# For C99 support to TR1.
GLIBCXX_CHECK_C99_TR1