aboutsummaryrefslogtreecommitdiff
path: root/libstdc++-v3/include/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Kosnik <bkoz@redhat.com>2003-06-11 15:52:11 +0000
committerBenjamin Kosnik <bkoz@redhat.com>2003-06-11 15:52:11 +0000
commit949ce1bf78958adfc5efcd72b0ff57fce8403acf (patch)
tree61989852861e8690ab5a873c759b5218e2280ca7 /libstdc++-v3/include/Makefile.am
parent7ef57f2c84bd427d049e58b41fce137634e1a21c (diff)
2003-06-11 Benjamin Kosnik <bkoz@redhat.com>
* include/bits/stl_alloc.h (__debug_alloc): Move out. (__malloc_alloc): Same. (__pool_alloc): Same. (__new_alloc): Same. Rename to.. * include/bits/allocator.h: ...this. * include/bits/stl_deque.h: Modify comment. * include/bits/stl_tree.h: Modify include. * include/std/std_memory.h: Same. * include/ext/rope: Same. * include/ext/slist: Same. * include/std/std_vector.h: Same. * include/std/std_stack.h: Same. * include/std/std_queue.h: Same. * include/std/std_list.h: Same. * include/std/std_deque.h: Same. * include/backward/alloc.h: Same. * include/ext/debug_allocator.h: New. * include/ext/malloc_allocator.h: New. * include/ext/pool_allocator.h: New. * include/ext/new_allocator.h: New. * include/bits/pthread_allocimpl.h: Remove. * include/bits/stl_pthread_alloc.h: Remove. * include/Makefile.am (ext_headers): Add. * include/Makefile.in: Regenerate. * src/stl-inst.cc: Use __gnu_cxx namespace. * src/stl-inst.cc: Move to... * src/allocator-inst.cc: Here. * src/Makefile.am (sources): Update. * src/Makefile.in: Regenerate. * config/linker-map.gnu: Remove __pool_alloc bits. * testsuite/ext/headers.cc: Add. * testsuite/ext/allocators.cc: Fixup. 2003-06-11 Stefan Olsson <stefan@snon.net> Ola R�nnerup <fnolis@home.se> * include/Makefile.am (ext_headers): Add. * include/Makefile.in: Regenerate. * include/ext/mt_allocator.h: New file. git-svn-id: https://gcc.gnu.org/svn/gcc/trunk@67777 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/include/Makefile.am')
-rw-r--r--libstdc++-v3/include/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/libstdc++-v3/include/Makefile.am b/libstdc++-v3/include/Makefile.am
index 5c200dcd8a7..760e85ba4e8 100644
--- a/libstdc++-v3/include/Makefile.am
+++ b/libstdc++-v3/include/Makefile.am
@@ -103,6 +103,8 @@ std_headers_rename = \
bits_srcdir = ${glibcpp_srcdir}/include/bits
bits_builddir = ./bits
bits_headers = \
+ ${bits_srcdir}/allocator.h \
+ ${bits_srcdir}/allocator_traits.h \
${bits_srcdir}/basic_ios.h \
${bits_srcdir}/basic_ios.tcc \
${bits_srcdir}/basic_string.h \
@@ -129,14 +131,12 @@ bits_headers = \
${bits_srcdir}/localefwd.h \
${bits_srcdir}/mask_array.h \
${bits_srcdir}/ostream.tcc \
- ${bits_srcdir}/pthread_allocimpl.h \
${bits_srcdir}/stream_iterator.h \
${bits_srcdir}/streambuf_iterator.h \
${bits_srcdir}/slice_array.h \
${bits_srcdir}/sstream.tcc \
${bits_srcdir}/stl_algo.h \
${bits_srcdir}/stl_algobase.h \
- ${bits_srcdir}/stl_alloc.h \
${bits_srcdir}/stl_bvector.h \
${bits_srcdir}/stl_construct.h \
${bits_srcdir}/stl_deque.h \
@@ -151,7 +151,6 @@ bits_headers = \
${bits_srcdir}/stl_multiset.h \
${bits_srcdir}/stl_numeric.h \
${bits_srcdir}/stl_pair.h \
- ${bits_srcdir}/stl_pthread_alloc.h \
${bits_srcdir}/stl_queue.h \
${bits_srcdir}/stl_raw_storage_iter.h \
${bits_srcdir}/stl_relops.h \
@@ -215,6 +214,7 @@ ext_srcdir = ${glibcpp_srcdir}/include/ext
ext_builddir = ./ext
ext_headers = \
${ext_srcdir}/algorithm \
+ ${ext_srcdir}/debug_allocator.h \
${ext_srcdir}/enc_filebuf.h \
${ext_srcdir}/stdio_filebuf.h \
${ext_srcdir}/stdio_sync_filebuf.h \
@@ -222,8 +222,12 @@ ext_headers = \
${ext_srcdir}/hash_map \
${ext_srcdir}/hash_set \
${ext_srcdir}/iterator \
+ ${ext_srcdir}/malloc_allocator.h \
${ext_srcdir}/memory \
+ ${ext_srcdir}/mt_allocator.h \
+ ${ext_srcdir}/new_allocator.h \
${ext_srcdir}/numeric \
+ ${ext_srcdir}/pool_allocator.h \
${ext_srcdir}/rb_tree \
${ext_srcdir}/rope \
${ext_srcdir}/ropeimpl.h \