aboutsummaryrefslogtreecommitdiff
path: root/libstdc++-v3/include/Makefile.am
diff options
context:
space:
mode:
authorPaul Brook <paul@codesourcery.com>2004-07-02 23:40:19 +0000
committerPaul Brook <paul@codesourcery.com>2004-07-02 23:40:19 +0000
commitcd28e1019b7f714990863def896ed612581e966d (patch)
tree4ee3482f74ebfac6d6e99562f108ef088befc592 /libstdc++-v3/include/Makefile.am
parent5549ff4068497a5e9ee562c711353f360d4444b6 (diff)
* configure.ac: Set ABI_TWEAKS_SRCDIR.
* configure.host: Set abi_tweaks_dir. Check for atomicity.h when setting atomicity_dir. Override type_cpu for arm based targets. * include/Makefile.am (host_headers): Add cxxabi_tweaks.h. * libsupc++/cxxabi.h: Include bits/cxxabi.h. Don't declare __guard. * libsupc++/guard.cc: Use definitions from cxxabi_tweaks.h. * libsupc++/vec.cc: Ditto. * config/cpu/arm/cxxabi_tweaks.h: New file. * config/cpu/generic/cxxabi_tweaks.h: New file. * */Makefile.in: Regenerate. * configure: Regenerate. git-svn-id: https://gcc.gnu.org/svn/gcc/trunk@84032 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/include/Makefile.am')
-rw-r--r--libstdc++-v3/include/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/libstdc++-v3/include/Makefile.am b/libstdc++-v3/include/Makefile.am
index d3d3872a07a..5ff38983d23 100644
--- a/libstdc++-v3/include/Makefile.am
+++ b/libstdc++-v3/include/Makefile.am
@@ -340,7 +340,8 @@ host_headers = \
${host_srcdir}/ctype_inline.h \
${host_srcdir}/ctype_noninline.h \
${host_srcdir}/os_defines.h \
- ${glibcxx_srcdir}/$(ATOMIC_WORD_SRCDIR)/atomic_word.h
+ ${glibcxx_srcdir}/$(ATOMIC_WORD_SRCDIR)/atomic_word.h \
+ ${glibcxx_srcdir}/$(ABI_TWEAKS_SRCDIR)/cxxabi_tweaks.h
# Non-installed host_header files.
host_headers_noinst = \