aboutsummaryrefslogtreecommitdiff
path: root/libstdc++-v3/include/Makefile.am
diff options
context:
space:
mode:
authorDavid Edelsohn <dje@gcc.gnu.org>2005-09-13 19:22:52 +0000
committerBenjamin Kosnik <bkoz@redhat.com>2005-09-13 19:22:52 +0000
commitd079d205b9907be2bf54bc8656d22e2b74f573e4 (patch)
treef548dd3737f17a69909461a772f76a25e19459c3 /libstdc++-v3/include/Makefile.am
parent092526348d3d6a2ff7a9b4a30f94f70a05484681 (diff)
2005-09-12 David Edelsohn <dje@gcc.gnu.org>
PR libstdc++/22554 PR libstdc++/23734 * include/Makefile.am (stamp-assoc): Install each subgroup of headers separately. * include/Makefile.in: Regenerate. git-svn-id: https://gcc.gnu.org/svn/gcc/trunk@104238 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/include/Makefile.am')
-rw-r--r--libstdc++-v3/include/Makefile.am54
1 files changed, 31 insertions, 23 deletions
diff --git a/libstdc++-v3/include/Makefile.am b/libstdc++-v3/include/Makefile.am
index 185a8f36c78..ed39973ee3a 100644
--- a/libstdc++-v3/include/Makefile.am
+++ b/libstdc++-v3/include/Makefile.am
@@ -744,29 +744,37 @@ stamp-ext: ${ext_headers}
stamp-assoc:
@if [ ! -d "${assoc_builddir}" ]; then \
mkdir -p ${assoc_subdirs} ;\
- fi ;\
- if [ ! -f stamp-assoc ]; then \
- (cd ${assoc_builddir} && for h in ${assoc_headers1}; do \
- build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
- $(LN_S) $$h $${build_name} || true ;\
- done) ;\
- (cd ${assoc_builddir} && for h in ${assoc_headers2}; do \
- build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
- $(LN_S) $$h $${build_name} || true ;\
- done) ;\
- (cd ${assoc_builddir} && for h in ${assoc_headers3}; do \
- build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
- $(LN_S) $$h $${build_name} || true ;\
- done) ;\
- (cd ${assoc_builddir} && for h in ${assoc_headers4}; do \
- build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
- $(LN_S) $$h $${build_name} || true ;\
- done) ;\
- (cd ${assoc_builddir} && for h in ${assoc_headers5}; do \
- build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
- $(LN_S) $$h $${build_name} || true ;\
- done) ;\
- fi ;\
+ fi
+ @if [ ! -f stamp-assoc ]; then \
+ cd ${assoc_builddir} && for h in ${assoc_headers1}; do \
+ build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
+ $(LN_S) $$h $${build_name} || true ;\
+ done ;\
+ fi
+ @if [ ! -f stamp-assoc ]; then \
+ cd ${assoc_builddir} && for h in ${assoc_headers2}; do \
+ build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
+ $(LN_S) $$h $${build_name} || true ;\
+ done ;\
+ fi
+ @if [ ! -f stamp-assoc ]; then \
+ cd ${assoc_builddir} && for h in ${assoc_headers3}; do \
+ build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
+ $(LN_S) $$h $${build_name} || true ;\
+ done ;\
+ fi
+ @if [ ! -f stamp-assoc ]; then \
+ cd ${assoc_builddir} && for h in ${assoc_headers4}; do \
+ build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
+ $(LN_S) $$h $${build_name} || true ;\
+ done ;\
+ fi
+ @if [ ! -f stamp-assoc ]; then \
+ cd ${assoc_builddir} && for h in ${assoc_headers5}; do \
+ build_name=`echo $$h | sed -e "s|${assoc_srcdir}|.|g"` ;\
+ $(LN_S) $$h $${build_name} || true ;\
+ done ;\
+ fi
$(STAMP) stamp-assoc
stamp-tr1: ${tr1_headers}