aboutsummaryrefslogtreecommitdiff
path: root/boehm-gc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'boehm-gc/configure.in')
-rw-r--r--boehm-gc/configure.in47
1 files changed, 3 insertions, 44 deletions
diff --git a/boehm-gc/configure.in b/boehm-gc/configure.in
index 6a75b192b70..c8c64a4c1b8 100644
--- a/boehm-gc/configure.in
+++ b/boehm-gc/configure.in
@@ -2,11 +2,6 @@ dnl Process this file with autoconf to produce configure.
AC_INIT(gc_mark.h)
-dnl Can't be done in BOEHM_CONFIGURE because that confuses automake.
-AC_CONFIG_AUX_DIR(..)
-
-AC_CANONICAL_SYSTEM
-
BOEHM_CONFIGURE(.)
AM_PROG_LIBTOOL
@@ -26,44 +21,9 @@ if test "x" = "y"; then
AC_EXEEXT
fi
-AC_MSG_CHECKING([for threads package to use])
-AC_ARG_ENABLE(threads, [ --enable-threads=TYPE choose threading package],
- THREADS=$enableval,
- dnl FIXME: figure out native threads to use here.
- THREADS=no)
-
-if test "$THREADS" = yes; then
- case "$host" in
- *-*-vxworks*)
- THREADS=vxworks
- ;;
- *-*-linux*)
- # FIXME: this isn't correct in all cases.
- THREADS=posix
- ;;
- *-*-win*)
- THREADS=win32
- ;;
- *-*-irix[[1-5]].*)
- # No built-in threads library on IRIX 5.* and older.
- THREADS=none
- ;;
- *-*-irix*)
- # FIXME: for now, choose POSIX, because we implement that.
- # Later, choose irix threads.
- THREADS=posix
- ;;
- *-*-solaris*)
- # FIXME: for now, choose POSIX, because we implement that.
- # Later, choose solaris threads.
- THREADS=posix
- ;;
- *)
- # For now.
- THREADS=none
- ;;
- esac
-fi
+AC_MSG_CHECKING([for thread model used by GCC])
+THREADS=`$CC -v 2>&1 | sed -n 's/^Thread model: //p'`
+AC_MSG_RESULT([$THREADS])
INCLUDES=
THREADLIBS=
@@ -95,7 +55,6 @@ case "$THREADS" in
AC_MSG_ERROR($THREADS is an unknown thread package)
;;
esac
-AC_MSG_RESULT($THREADS)
AC_SUBST(THREADLIBS)
AC_CHECK_LIB(dl, dlopen, EXTRA_TEST_LIBS="$EXTRA_TEST_LIBS -ldl")