aboutsummaryrefslogtreecommitdiff
path: root/fixincludes/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'fixincludes/configure.ac')
-rw-r--r--fixincludes/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/fixincludes/configure.ac b/fixincludes/configure.ac
index 46296049f31..04305fe63b7 100644
--- a/fixincludes/configure.ac
+++ b/fixincludes/configure.ac
@@ -6,6 +6,18 @@ AC_CONFIG_AUX_DIR(..)
AC_CANONICAL_SYSTEM
AC_PROG_CC
+# Figure out what compiler warnings we can enable.
+# See config/warnings.m4 for details.
+
+ACX_PROG_CC_WARNING_OPTS([-W -Wall -Wwrite-strings -Wstrict-prototypes \
+ -Wmissing-prototypes -Wold-style-definition \
+ -Wmissing-format-attribute])
+ACX_PROG_CC_WARNING_ALMOST_PEDANTIC([-Wno-long-long])
+
+# Only enable with --enable-werror-always until existing warnings are
+# corrected.
+ACX_PROG_CC_WARNINGS_ARE_ERRORS([manual])
+
# Determine the noncanonical target name, for directory use.
ACX_NONCANONICAL_TARGET