aboutsummaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 6bca2954e38..31b448720a2 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -323,8 +323,7 @@ AC_CHECK_TYPES([__int64], [AC_CHECK_SIZEOF(__int64)])
# So, we only use -pedantic if we can disable those warnings.
ACX_PROG_CC_WARNING_OPTS([-W -Wall -Wwrite-strings -Wstrict-prototypes \
- -Wmissing-prototypes], [loose_warn])
-ACX_PROG_CC_WARNING_OPTS([-Wc++-compat], [cxx_compat_warn])
+ -Wmissing-prototypes -Wcast-qual -Wc++-compat], [loose_warn])
ACX_PROG_CC_WARNING_OPTS([-Wold-style-definition \
-Wmissing-format-attribute], [strict_warn])
ACX_PROG_CC_WARNING_ALMOST_PEDANTIC([-Wno-long-long -Wno-variadic-macros \