aboutsummaryrefslogtreecommitdiff
path: root/libf2c/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'libf2c/configure.in')
-rw-r--r--libf2c/configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/libf2c/configure.in b/libf2c/configure.in
index ce6ac199b90..8b2e26ab8e4 100644
--- a/libf2c/configure.in
+++ b/libf2c/configure.in
@@ -1,5 +1,5 @@
# Process this file with autoconf to produce a configure script.
-# Copyright (C) 1995, 1997, 1998, 1999 Free Software Foundation, Inc.
+# Copyright (C) 1995, 1997, 1998, 1999, 2002 Free Software Foundation, Inc.
# Contributed by Dave Love (d.love@dl.ac.uk).
#
#This file is part of GNU Fortran.
@@ -22,6 +22,14 @@
AC_PREREQ(2.13)
AC_INIT(libF77/Version.c)
+# This works around the fact that libtool configuration may change LD
+# for this particular configuration, but some shells, instead of
+# keeping the changes in LD private, export them just because LD is
+# exported.
+ORIGINAL_LD_FOR_MULTILIBS=$LD
+
+GLIBCPP_TOPREL_CONFIGURE
+
AC_CANONICAL_SYSTEM
target_alias=${target_alias-$target}
AC_SUBST(target_alias)
@@ -113,6 +121,7 @@ AC_CONFIG_SUBDIRS(libU77 libI77 libF77)
AC_OUTPUT(Makefile g2c.h:g2c.hin,
[test -z "$CONFIG_HEADERS" || echo timestamp > stamp-h
if test -n "$CONFIG_FILES"; then
+ LD="${ORIGINAL_LD_FOR_MULTILIBS}"
if test -n "${with_target_subdir}"; then
# FIXME: We shouldn't need to set ac_file
ac_file=Makefile