aboutsummaryrefslogtreecommitdiff
path: root/libf2c/libI77/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'libf2c/libI77/configure.in')
-rw-r--r--libf2c/libI77/configure.in19
1 files changed, 12 insertions, 7 deletions
diff --git a/libf2c/libI77/configure.in b/libf2c/libI77/configure.in
index 7e920f91abd..20f2628ba3a 100644
--- a/libf2c/libI77/configure.in
+++ b/libf2c/libI77/configure.in
@@ -1,5 +1,5 @@
# Process this file with autoconf to produce a configure script.
-# Copyright (C) 1995, 1997, 1998 Free Software Foundation, Inc.
+# Copyright (C) 1995, 1997, 1998, 2001 Free Software Foundation, Inc.
# Contributed by Dave Love (d.love@dl.ac.uk).
#
#This file is part of GNU Fortran.
@@ -21,6 +21,7 @@
AC_PREREQ(2.12.1)
AC_INIT(ftell_.c)
+AC_CONFIG_HEADER(config.h)
dnl Checks for programs.
@@ -112,7 +113,8 @@ AC_MSG_RESULT($g77_cv_sys_mingw32)
AC_CHECK_HEADER(fcntl.h,
test $g77_cv_header_posix = yes && AC_DEFINE(_POSIX_SOURCE),
- AC_DEFINE(NO_FCNTL) AC_DEFINE(OPEN_DECL))
+ AC_DEFINE(NO_FCNTL, 1, [Define if fcntl.h is missing.])
+ AC_DEFINE(OPEN_DECL, 1, [Define if fcntl.h is missing.]))
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -129,11 +131,12 @@ if test $g77_cv_sys_cygwin32 = yes \
|| test $g77_cv_sys_mingw32 = yes \
|| test $ac_cv_func_fstat = no; then
AC_MSG_RESULT(yes)
- AC_DEFINE(NON_UNIX_STDIO)
+ AC_DEFINE(NON_UNIX_STDIO, 1, [Define if we do not have Unix Stdio.])
else
AC_MSG_RESULT(no)
fi
+AC_CHECK_FUNCS(ftruncate)
AC_CHECK_FUNCS(mkstemp)
AC_CHECK_FUNCS(tempnam)
@@ -161,7 +164,7 @@ AC_MSG_RESULT($g77_cv_sys_sprintf_ansi)
# The cygwin patch takes steps to avoid defining USE_STRLEN here -- I don't
# understand why.
if test $g77_cv_sys_sprintf_ansi != yes; then
- AC_DEFINE(USE_STRLEN)
+ AC_DEFINE(USE_STRLEN, 1, [Define if we use strlen.])
fi
# define NON_ANSI_RW_MODES on unix (can't hurt)
@@ -182,7 +185,7 @@ if test $g77_cv_sys_cygwin32 = yes || test $g77_cv_sys_mingw32 = yes; then
AC_MSG_RESULT(no)
else
if test $is_unix = yes; then
- AC_DEFINE(NON_ANSI_RW_MODES)
+ AC_DEFINE(NON_ANSI_RW_MODES, 1, [Define if we have non ANSI RW modes.])
AC_MSG_RESULT(yes)
else
AC_MSG_RESULT(no)
@@ -190,9 +193,11 @@ else
fi
# This EOF_CHAR is a misfeature on unix.
-AC_DEFINE(NO_EOF_CHAR_CHECK)
+AC_DEFINE(NO_EOF_CHAR_CHECK, 1, [Always defined.])
-AC_DEFINE(Skip_f2c_Undefs)
+AC_TYPE_OFF_T
+
+AC_DEFINE(Skip_f2c_Undefs, 1, [Define to skip f2c undefs.])
AC_OUTPUT(Makefile)