aboutsummaryrefslogtreecommitdiff
path: root/libjava/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'libjava/configure.in')
-rw-r--r--libjava/configure.in253
1 files changed, 127 insertions, 126 deletions
diff --git a/libjava/configure.in b/libjava/configure.in
index 38ccec5ac0e..c40405f14ef 100644
--- a/libjava/configure.in
+++ b/libjava/configure.in
@@ -1,14 +1,14 @@
-dnl Process this with autoconf to create configure
+dnl # Process this with autoconf to create configure
AC_PREREQ(2.59)
AC_INIT(java/lang/System.java)
-dnl We use these options to decide which functions to include.
+# We use these options to decide which functions to include.
AC_ARG_WITH(target-subdir,
-[ --with-target-subdir=SUBDIR
- configuring in a subdirectory])
+ AS_HELP_STRING([--with-target-subdir=SUBDIR],
+ [configure in a subdirectory]))
-dnl We may get other options which we don't document:
-dnl --with-target-subdir, --with-multisrctop, --with-multisubdir
+# We may get other options which we don't document:
+# --with-target-subdir, --with-multisrctop, --with-multisubdir
# When building with srcdir == objdir, links to the source files will
# be created in directories within the target_subdir. We have to
@@ -58,15 +58,16 @@ mkinstalldirs="`cd $ac_aux_dir && ${PWDCMD-pwd}`/mkinstalldirs"
AC_SUBST(mkinstalldirs)
AC_ARG_WITH(cross-host,
-[ --with-cross-host=HOST configuring with a cross compiler])
+ AS_HELP_STRING([--with-cross-host=HOST],
+ [configure with a cross compiler from HOST]))
AC_ARG_WITH(newlib,
-[ --with-newlib Configuring with newlib])
+ AS_HELP_STRING([--with-newlib],
+ [configure with newlib]))
AC_ARG_ENABLE(version-specific-runtime-libs,
-[ --enable-version-specific-runtime-libs
- specify that runtime libraries should be installed in a compiler-specific
- directory ],
+ AS_HELP_STRING([--enable-version-specific-runtime-libs],
+ [specify that runtime libraries should be installed in a compiler-specific directory]),
[case "$enableval" in
yes) version_specific_libs=yes ;;
no) version_specific_libs=no ;;
@@ -75,16 +76,17 @@ AC_ARG_ENABLE(version-specific-runtime-libs,
[version_specific_libs=no]
)
-dnl Default to --enable-multilib
+# Default to --enable-multilib
AC_ARG_ENABLE(multilib,
-[ --enable-multilib build many library versions (default)],
+ AS_HELP_STRING([--enable-multilib],
+ [build many library versions (default)]),
[case "${enableval}" in
yes) multilib=yes ;;
no) multilib=no ;;
*) AC_MSG_ERROR(bad value ${enableval} for multilib option) ;;
esac], [multilib=yes])dnl
-dnl # It may not be safe to run linking tests in AC_PROG_CC/AC_PROG_CXX.
+# It may not be safe to run linking tests in AC_PROG_CC/AC_PROG_CXX.
GCC_NO_EXECUTABLES
# (1) We use an abnormal CXX (without library references), so we
@@ -110,9 +112,9 @@ AC_SUBST(CFLAGS)
AC_SUBST(CXXFLAGS)
AC_SUBST(LDFLAGS)
-dnl version is pulled out to make it a bit easier to change using sed.
+# version is pulled out to make it a bit easier to change using sed.
version=0.0.7
-dnl Still use "libjava" here to placate dejagnu.
+# Still use "libjava" here to placate dejagnu.
AM_INIT_AUTOMAKE(libjava, $version)
AC_CHECK_TOOL(AS, as)
@@ -134,11 +136,11 @@ libgcj_cflags=
libgcj_cxxflags=
libgcj_javaflags=
-. [$]{srcdir}/configure.host
+. ${srcdir}/configure.host
-LIBGCJ_CFLAGS="[$]{libgcj_cflags}"
-LIBGCJ_CXXFLAGS="[$]{libgcj_cxxflags}"
-LIBGCJ_JAVAFLAGS="[$]{libgcj_javaflags}"
+LIBGCJ_CFLAGS="${libgcj_cflags}"
+LIBGCJ_CXXFLAGS="${libgcj_cxxflags}"
+LIBGCJ_JAVAFLAGS="${libgcj_javaflags}"
AC_SUBST(LIBGCJ_CFLAGS)
AC_SUBST(LIBGCJ_CXXFLAGS)
AC_SUBST(LIBGCJ_JAVAFLAGS)
@@ -170,16 +172,16 @@ else
fi
AC_SUBST(COMPPATH)
-dnl The -no-testsuite modules omit the test subdir.
+# The -no-testsuite modules omit the test subdir.
AM_CONDITIONAL(TESTSUBDIR, test -d $srcdir/testsuite)
-dnl Should the runtime set system properties by examining the
-dnl environment variable GCJ_PROPERTIES?
+# Should the runtime set system properties by examining the
+# environment variable GCJ_PROPERTIES?
AC_ARG_ENABLE(getenv-properties,
-[ --disable-getenv-properties
- don't set system properties from GCJ_PROPERTIES])
+ AS_HELP_STRING([--disable-getenv-properties],
+ [don't set system properties from GCJ_PROPERTIES]))
-dnl Whether GCJ_PROPERTIES is used depends on the target.
+# Whether GCJ_PROPERTIES is used depends on the target.
if test -z "$enable_getenv_properties"; then
enable_getenv_properties=${enable_getenv_properties_default-yes}
fi
@@ -188,7 +190,7 @@ if test "$enable_getenv_properties" = no; then
[Define if system properties shouldn't be read from getenv("GCJ_PROPERTIES").])
fi
-dnl Whether we should use arguments to main()
+# Whether we should use arguments to main()
if test -z "$enable_main_args"; then
enable_main_args=${enable_main_args_default-yes}
fi
@@ -197,12 +199,12 @@ if test "$enable_main_args" = no; then
fi
-dnl Should we use hashtable-based synchronization?
-dnl Currently works only for Linux X86/ia64
-dnl Typically faster and more space-efficient
+# Should we use hashtable-based synchronization?
+# Currently works only for Linux X86/ia64
+# Typically faster and more space-efficient
AC_ARG_ENABLE(hash-synchronization,
-[ --enable-hash-synchronization
- use global hash table for monitor locks])
+ AS_HELP_STRING([--enable-hash-synchronization],
+ [use global hash table for monitor locks]))
if test -z "$enable_hash_synchronization"; then
enable_hash_synchronization=$enable_hash_synchronization_default
@@ -210,8 +212,8 @@ fi
# Do we allow intermodule optimizations (i.e. compiling many files at once)?
AC_ARG_ENABLE(libgcj-multifile,
-[ --enable-libgcj-multifile
- allow compilation of several files at once],
+ AS_HELP_STRING([--enable-libgcj-multifile]
+ [allow compilation of several files at once]),
[case "${enableval}" in
yes) enable_libgcj_multifile=yes ;;
no) enable_libgcj_multifile=no ;;
@@ -221,10 +223,8 @@ AM_CONDITIONAL(ONESTEP, test "$enable_libgcj_multifile" = yes)
# What is the native OS API for MinGW?
AC_ARG_WITH(win32-nlsapi,
-changequote(<<,>>)dnl
-<< --with-win32-nlsapi=ansi, unicows or unicode
- native MinGW libgcj Win32 OS API [ansi]>>,
-changequote([,])
+ AS_HELP_STRING([--with-win32-nlsapi=ansi or unicows or unicode],
+ [native MinGW libgcj Win32 OS API (default is ansi)]),
[case "${withval}" in
ansi) with_win32_nlsapi=ansi ;;
unicows) with_win32_nlsapi=unicows ;;
@@ -239,33 +239,35 @@ case "${with_win32_nlsapi}" in
;;
esac
-dnl configure.host sets slow_pthread_self if the synchronization code should
-dnl try to avoid pthread_self calls by caching thread IDs in a hashtable.
+# configure.host sets slow_pthread_self if the synchronization code should
+# try to avoid pthread_self calls by caching thread IDs in a hashtable.
if test "${slow_pthread_self}" = "yes"; then
AC_DEFINE(SLOW_PTHREAD_SELF, 1,
[Define if if the synchronization code should try to avoid pthread_self calls by caching thread IDs in a hashtable.])
fi
-dnl See if the user has requested runtime debugging.
+# See if the user has requested runtime debugging.
LIBGCJDEBUG="false"
AC_SUBST(LIBGCJDEBUG)
AC_ARG_ENABLE(libgcj-debug,
-[ --enable-libgcj-debug enable runtime debugging code],
- if test "$enable_libgcj_debug" = yes; then
+ AS_HELP_STRING([--enable-libgcj-debug],
+ [enable runtime debugging code]),
+ [if test "$enable_libgcj_debug" = yes; then
AC_DEFINE(DEBUG, 1, [Define this if you want runtime debugging enabled.])
LIBGCJDEBUG="true"
- fi)
+ fi])
-dnl See if the user has the interpreter included.
+# See if the user has the interpreter included.
AC_ARG_ENABLE(interpreter,
-[ --enable-interpreter enable interpreter],
- if test "$enable_interpreter" = yes; then
+ AS_HELP_STRING([--enable-interpreter],
+ [enable interpreter]),
+ [if test "$enable_interpreter" = yes; then
# This can also be set in configure.host.
libgcj_interpreter=yes
elif test "$enable_interpreter" = no; then
libgcj_interpreter=no
- fi)
+ fi])
if test "$libgcj_interpreter" = yes; then
AC_DEFINE(INTERPRETER, 1, [Define if you want a bytecode interpreter.])
@@ -277,7 +279,8 @@ AC_MSG_CHECKING([for exception model to use])
AC_LANG_SAVE
AC_LANG_CPLUSPLUS
AC_ARG_ENABLE(sjlj-exceptions,
-[ --enable-sjlj-exceptions force use of builtin_setjmp for exceptions],
+ AS_HELP_STRING([--enable-sjlj-exceptions],
+ [force use of builtin_setjmp for exceptions]),
[:],
[dnl Botheration. Now we've got to detect the exception model.
dnl Link tests against libgcc.a are problematic since -- at least
@@ -327,12 +330,13 @@ if test $can_unwind_signal = no && test $enable_sjlj_exceptions = no; then
EXCEPTIONSPEC=
fi
-dnl See if the user wants to disable java.net. This is the mildly
-dnl ugly way that we admit that target-side configuration sucks.
+# See if the user wants to disable java.net. This is the mildly
+# ugly way that we admit that target-side configuration sucks.
AC_ARG_ENABLE(java-net,
-[ --disable-java-net disable java.net])
+ AS_HELP_STRING([--disable-java-net],
+ [disable java.net]))
-dnl Whether java.net is built by default can depend on the target.
+# Whether java.net is built by default can depend on the target.
if test -z "$enable_java_net"; then
enable_java_net=${enable_java_net_default-yes}
fi
@@ -340,11 +344,14 @@ if test "$enable_java_net" = no; then
AC_DEFINE(DISABLE_JAVA_NET, 1, [Define if java.net native functions should be stubbed out.])
fi
-dnl See if the user wants to configure without libffi. Some
-dnl architectures don't support it, and default values are set in
-dnl configure.host.
+# See if the user wants to configure without libffi. Some
+# architectures don't support it, and default values are set in
+# configure.host.
AC_ARG_WITH(libffi,
-[ --without-libffi don't use libffi],,with_libffi=${with_libffi_default-yes})
+ AS_HELP_STRING([--without-libffi],
+ [don't use libffi]),
+ [:],
+ [with_libffi=${with_libffi_default-yes}])
LIBFFI=
LIBFFIINCS=
@@ -356,18 +363,19 @@ fi
AC_SUBST(LIBFFI)
AC_SUBST(LIBFFIINCS)
-dnl See if the user wants to disable JVMPI support.
+# See if the user wants to disable JVMPI support.
AC_ARG_ENABLE(jvmpi,
-[ --disable-jvmpi disable JVMPI support])
+ AS_HELP_STRING([--disable-jvmpi],
+ [disable JVMPI support]))
if test "$enable_jvmpi" != no; then
AC_DEFINE(ENABLE_JVMPI, 1, [Define if you are using JVMPI.])
fi
-dnl If the target is an eCos system, use the appropriate eCos
-dnl I/O routines.
-dnl FIXME: this should not be a local option but a global target
-dnl system; at present there is no eCos target.
+# If the target is an eCos system, use the appropriate eCos
+# I/O routines.
+# FIXME: this should not be a local option but a global target
+# system; at present there is no eCos target.
TARGET_ECOS=${PROCESS-"no"}
AC_ARG_WITH(ecos,
[ --with-ecos enable runtime eCos target support],
@@ -404,7 +412,7 @@ case "$TARGET_ECOS" in
;;
esac
AC_SUBST(PLATFORMOBJS)
-AC_LINK_FILES(include/$PLATFORMH, include/platform.h)
+AC_CONFIG_LINKS(include/platform.h:include/$PLATFORMH)
AC_EGREP_HEADER(uint32_t, stdint.h, AC_DEFINE(HAVE_INT32_DEFINED, 1,
[Define if you have int32_t and uint32_t.]))
@@ -416,42 +424,42 @@ AC_EGREP_HEADER(u_int32_t, sys/config.h, AC_DEFINE(HAVE_BSD_INT32_DEFINED, 1,
[Define if you have u_int32_t]))
-dnl These may not be defined in a non-ANS conformant embedded system.
-dnl FIXME: Should these case a runtime exception in that case?
+# These may not be defined in a non-ANS conformant embedded system.
+# FIXME: Should these case a runtime exception in that case?
AC_EGREP_HEADER(mktime, time.h, AC_DEFINE(HAVE_MKTIME, 1,
[Define is you have 'mktime' in <time.h>]))
AC_EGREP_HEADER(localtime, time.h, AC_DEFINE(HAVE_LOCALTIME, 1,
[Define is you have 'localtime' in <time.h>]))
-dnl Create the subdirectory for natFile.cc, or the attempt
-dnl to create the link will fail.
+# Create the subdirectory for natFile.cc, or the attempt
+# to create the link will fail.
test -d java || mkdir java
test -d java/io || mkdir java/io
test -d gnu || mkdir gnu
-AC_LINK_FILES(java/io/natFile${FILE-${PLATFORM}}.cc, java/io/natFile.cc)
+AC_CONFIG_LINKS(java/io/natFile.cc:java/io/natFile${FILE-${PLATFORM}}.cc)
-dnl Likewise for ConcreteProcess.java and natConcreteProcess.cc.
+# Likewise for ConcreteProcess.java and natConcreteProcess.cc.
test -d java/lang || mkdir java/lang
-AC_LINK_FILES(java/lang/${PLATFORM}Process.java, java/lang/ConcreteProcess.java)
-AC_LINK_FILES(java/lang/nat${PLATFORM}Process.cc, java/lang/natConcreteProcess.cc)
+AC_CONFIG_LINKS(java/lang/ConcreteProcess.java:java/lang/${PLATFORM}Process.java)
+AC_CONFIG_LINKS(java/lang/natConcreteProcess.cc:java/lang/nat${PLATFORM}Process.cc)
-dnl Likewise for natInetAddress.cc and natNetworkInterface.cc.
+# Likewise for natInetAddress.cc and natNetworkInterface.cc.
test -d java/net || mkdir java/net
-AC_LINK_FILES(java/net/natInetAddress${PLATFORMNET}.cc, java/net/natInetAddress.cc)
-AC_LINK_FILES(java/net/natNetworkInterface${PLATFORMNET}.cc, java/net/natNetworkInterface.cc)
+AC_CONFIG_LINKS(java/net/natInetAddress.cc:java/net/natInetAddress${PLATFORMNET}.cc)
+AC_CONFIG_LINKS(java/net/natNetworkInterface.cc:java/net/natNetworkInterface${PLATFORMNET}.cc)
-dnl Likewise for natPlainSocketImpl.cc and natPlainDatagramSocketImpl.cc.
+# Likewise for natPlainSocketImpl.cc and natPlainDatagramSocketImpl.cc.
test -d gnu/java || mkdir gnu/java
test -d gnu/java/net || mkdir gnu/java/net
-AC_LINK_FILES(gnu/java/net/natPlainSocketImpl${PLATFORMNET}.cc, gnu/java/net/natPlainSocketImpl.cc)
-AC_LINK_FILES(gnu/java/net/natPlainDatagramSocketImpl${PLATFORMNET}.cc, gnu/java/net/natPlainDatagramSocketImpl.cc)
+AC_CONFIG_LINKS(gnu/java/net/natPlainSocketImpl.cc:gnu/java/net/natPlainSocketImpl${PLATFORMNET}.cc)
+AC_CONFIG_LINKS(gnu/java/net/natPlainDatagramSocketImpl.cc:gnu/java/net/natPlainDatagramSocketImpl${PLATFORMNET}.cc)
-dnl Likewise for natPipeImpl.cc and natSelectorImpl.cc.
+# Likewise for natPipeImpl.cc and natSelectorImpl.cc.
test -d gnu/java/nio || mkdir gnu/java/nio
-AC_LINK_FILES(gnu/java/nio/natPipeImpl${PLATFORM}.cc, gnu/java/nio/natPipeImpl.cc)
-AC_LINK_FILES(gnu/java/nio/natSelectorImpl${PLATFORM}.cc, gnu/java/nio/natSelectorImpl.cc)
+AC_CONFIG_LINKS(gnu/java/nio/natPipeImpl.cc:gnu/java/nio/natPipeImpl${PLATFORM}.cc)
+AC_CONFIG_LINKS(gnu/java/nio/natSelectorImpl.cc:gnu/java/nio/natSelectorImpl${PLATFORM}.cc)
test -d gnu/java/nio/channels || mkdir gnu/java/nio/channels
-AC_LINK_FILES(gnu/java/nio/channels/natFileChannel${FILE-${PLATFORM}}.cc, gnu/java/nio/channels/natFileChannelImpl.cc)
+AC_CONFIG_LINKS(gnu/java/nio/channels/natFileChannelImpl.cc:gnu/java/nio/channels/natFileChannel${FILE-${PLATFORM}}.cc)
case "${host}" in
*mingw*)
@@ -470,7 +478,8 @@ LIBGCJTESTSPEC="-L`${PWDCMD-pwd}`/.libs -rpath `${PWDCMD-pwd}`/.libs"
AC_SUBST(LIBGCJTESTSPEC)
AC_ARG_WITH(system-zlib,
-[ --with-system-zlib use installed libz])
+ AS_HELP_STRING([--with-system-zlib],
+ [use installed libz]))
ZLIBSPEC=
AC_SUBST(ZLIBSPEC)
ZLIBTESTSPEC=
@@ -478,9 +487,10 @@ AC_SUBST(ZLIBTESTSPEC)
AC_PATH_XTRA
-dnl Determine which AWT peer libraries to build
+# Determine which AWT peer libraries to build
AC_ARG_ENABLE(java-awt,
-[ --enable-java-awt list of AWT peer implementations to be built])
+ AS_HELP_STRING([--enable-java-awt],
+ [list of AWT peer implementations to be built]))
peerlibs="`echo ${enable_java_awt} | tr ',' ' '`"
use_xlib_awt=""
@@ -528,8 +538,10 @@ done
AM_CONDITIONAL(XLIB_AWT, test "$use_xlib_awt" = yes)
AM_CONDITIONAL(GTK_AWT, test "$use_gtk_awt" = yes)
-dnl determine whether to enable the cairo GTK Graphics2D backend
-AC_ARG_ENABLE(gtk-cairo, [ --enable-gtk-cairo build the cairo Graphics2D implementation on GTK])
+# determine whether to enable the cairo GTK Graphics2D backend
+AC_ARG_ENABLE(gtk-cairo,
+ AS_HELP_STRING([--enable-gtk-cairo],
+ [build the cairo Graphics2D implementation on GTK]))
AM_CONDITIONAL(GTK_CAIRO, test "x${enable_gtk_cairo}" = xyes)
if test "x${enable_gtk_cairo}" = xyes
then
@@ -541,17 +553,16 @@ AC_SUBST(CAIRO_CFLAGS)
AC_SUBST(PANGOFT2_LIBS)
AC_SUBST(PANGOFT2_CFLAGS)
-dnl FIXME: this should be _libs on some hosts.
+# FIXME: this should be _libs on some hosts.
libsubdir=.libs
-dnl Allow the GC to be disabled. Can be useful when debugging.
+# Allow the GC to be disabled. Can be useful when debugging.
AC_MSG_CHECKING([for garbage collector to use])
AC_ARG_ENABLE(java-gc,
-changequote(<<,>>)dnl
-<< --enable-java-gc=TYPE choose garbage collector [boehm]>>,
-changequote([,])
- GC=$enableval,
- GC=boehm)
+ AS_HELP_STRING([--enable-java-gc=TYPE],
+ [choose garbage collector (default is boehm)]),
+ [GC=$enableval],
+ [GC=boehm])
GCLIBS=
GCINCS=
GCDEPS=
@@ -566,12 +577,12 @@ case "$GC" in
JC1GCSPEC='-fuse-boehm-gc'
GCTESTSPEC="-L`${PWDCMD-pwd}`/../boehm-gc/.libs -rpath `${PWDCMD-pwd}`/../boehm-gc/.libs"
- dnl We also want to pick up some cpp flags required when including
- dnl boehm-config.h. Yuck.
+ # We also want to pick up some cpp flags required when including
+ # boehm-config.h. Yuck.
GCINCS="`cat ../boehm-gc/boehm-cflags`"
GCOBJS=boehm.lo
GCHDR=boehm-gc.h
- dnl The POSIX thread support needs to know this.
+ # The POSIX thread support needs to know this.
AC_DEFINE(HAVE_BOEHM_GC, 1, [Define if Boehm GC in use.])
;;
no)
@@ -590,7 +601,7 @@ AC_SUBST(GCOBJS)
AC_SUBST(GCSPEC)
AC_SUBST(JC1GCSPEC)
AC_SUBST(GCTESTSPEC)
-AC_LINK_FILES(include/$GCHDR, include/java-gc.h)
+AC_CONFIG_LINKS(include/java-gc.h:include/$GCHDR)
AC_MSG_CHECKING([for thread model used by GCC])
@@ -633,9 +644,7 @@ case "$THREADS" in
*-*-cygwin*)
# Don't set THREADLIBS here. Cygwin doesn't have -lpthread.
;;
-changequote(<<,>>)
- *-*-freebsd[1234]*)
-changequote([,])
+ *-*-freebsd[[1234]]*)
# Before FreeBSD 5, it didn't have -lpthread (or any library which
# merely adds pthread_* functions) but it does have a -pthread switch
# which is required at link-time to select -lc_r *instead* of -lc.
@@ -690,7 +699,7 @@ changequote([,])
THREADH=no-threads.h
;;
esac
-AC_LINK_FILES(include/$THREADH, include/java-threads.h)
+AC_CONFIG_LINKS(include/java-threads.h:include/$THREADH)
AC_SUBST(THREADLIBS)
AC_SUBST(THREADINCS)
AC_SUBST(THREADDEPS)
@@ -700,7 +709,7 @@ AC_SUBST(THREADLDFLAGS)
AC_SUBST(THREADCXXFLAGS)
if test -d sysdep; then true; else mkdir sysdep; fi
-AC_LINK_FILES(sysdep/$sysdeps_dir/locks.h, sysdep/locks.h)
+AC_CONFIG_LINKS(sysdep/locks.h:sysdep/$sysdeps_dir/locks.h)
HASH_SYNC_SPEC=
# Hash synchronization is only useful with posix threads right now.
@@ -717,12 +726,10 @@ AM_CONDITIONAL(USING_GCC, test "$GCC" = yes)
GCC_UNWIND_INCLUDE='-I$(libgcj_basedir)/../gcc'
# Figure out where generated headers like libgcj-config.h get installed.
-changequote(,)dnl
gcc_version_trigger=${libgcj_basedir}/../gcc/version.c
-gcc_version_full=`grep version_string ${gcc_version_trigger} | sed -e 's/.*\"\([^\"]*\)\".*/\1/'`
-gcc_version=`echo ${gcc_version_full} | sed -e 's/\([^ ]*\) .*/\1/'`
+gcc_version_full=`grep version_string ${gcc_version_trigger} | sed -e 's/.*\"\([[^\"]]*\)\".*/\1/'`
+gcc_version=`echo ${gcc_version_full} | sed -e 's/\([[^ ]]*\) .*/\1/'`
tool_include_dir='$(libdir)/gcc/$(target_noncanonical)/'${gcc_version}/include
-changequote([,])dnl
AC_SUBST(tool_include_dir)
AC_SUBST(gcc_version)
@@ -740,12 +747,12 @@ if test "x${with_newlib}" = "xyes"; then
AC_DEFINE(HAVE_GMTIME_R, 1, [Define if you have the 'gmtime_r' function])
AC_DEFINE(HAVE_LOCALTIME_R, 1, [Define if you have the 'localtime_r' function.])
AC_DEFINE(HAVE_USLEEP_DECL, 1, [Define if usleep is declared in <unistd.h>.])
- dnl This is only for POSIX threads.
+ # This is only for POSIX threads.
AC_DEFINE(HAVE_PTHREAD_MUTEXATTR_INIT, 1, [Define if using POSIX threads that have the mutexattr functions.])
- dnl We also assume we are using gcc, which provides alloca.
+ # We also assume we are using gcc, which provides alloca.
AC_DEFINE(HAVE_ALLOCA)
- dnl Assume we do not have getuid and friends.
+ # Assume we do not have getuid and friends.
AC_DEFINE(NO_GETUID, 1, [Define if getuid() and friends are missing.])
PLATFORMNET=NoNet
else
@@ -1017,9 +1024,7 @@ fi
if test -z "${with_multisubdir}"; then
builddotdot=.
else
-changequote(<<,>>)
- builddotdot=`echo ${with_multisubdir} | sed -e 's:[^/][^/]*:..:g'`
-changequote([,])
+ builddotdot=`echo ${with_multisubdir} | sed -e 's:[[^/]][[^/]]*:..:g'`
fi
NATIVE=yes
@@ -1180,19 +1185,17 @@ AC_SUBST(toolexecmainlibdir)
AC_SUBST(toolexeclibdir)
# Determine gcj version number.
-changequote(<<,>>)
-gcjversion=`$GCJ -v 2>&1 | sed -n 's/^.*version \([^ ]*\).*$/\1/p'`
-changequote([,])
+gcjversion=`$GCJ -v 2>&1 | sed -n 's/^.*version \([[^ ]]*\).*$/\1/p'`
GCJVERSION=$gcjversion
AC_SUBST(GCJVERSION)
AC_DEFINE_UNQUOTED(GCJVERSION, "$GCJVERSION", [Short GCJ version ID])
-dnl We check for sys/filio.h because Solaris 2.5 defines FIONREAD there.
-dnl On that system, sys/ioctl.h will not include sys/filio.h unless
-dnl BSD_COMP is defined; just including sys/filio.h is simpler.
+# We check for sys/filio.h because Solaris 2.5 defines FIONREAD there.
+# On that system, sys/ioctl.h will not include sys/filio.h unless
+# BSD_COMP is defined; just including sys/filio.h is simpler.
AC_CHECK_HEADERS(unistd.h bstring.h sys/time.h sys/types.h fcntl.h sys/ioctl.h sys/filio.h sys/stat.h sys/select.h sys/socket.h netinet/in.h arpa/inet.h netdb.h net/if.h pwd.h sys/config.h stdint.h langinfo.h locale.h)
-dnl We avoid AC_HEADER_DIRENT since we really only care about dirent.h
-dnl for now. If you change this, you also must update natFile.cc.
+# We avoid AC_HEADER_DIRENT since we really only care about dirent.h
+# for now. If you change this, you also must update natFile.cc.
AC_CHECK_HEADERS(dirent.h)
AC_CHECK_HEADERS(inttypes.h, [
AC_DEFINE(HAVE_INTTYPES_H, 1, [Define if <inttypes.h> is available])
@@ -1346,8 +1349,8 @@ if test -z "$SIGNAL_HANDLER_AUX"; then
SIGNAL_HANDLER_AUX=$SIGNAL_HANDLER
fi
-AC_LINK_FILES($SIGNAL_HANDLER $SIGNAL_HANDLER_AUX,
- include/java-signal.h include/java-signal-aux.h)
+AC_CONFIG_LINKS(include/java-signal.h:$SIGNAL_HANDLER
+ include/java-signal-aux.h:$SIGNAL_HANDLER_AUX)
if test "${multilib}" = "yes"; then
multilib_arg="--enable-multilib"
@@ -1383,9 +1386,7 @@ h=`${PWDCMD-pwd}`
while read f; do
echo "include $f" >> deps.mk
test -f $f || {
-changequote(<<,>>)
- d=`echo $f | sed -e 's,/[^/]*$,,'`
-changequote([,])
+ d=`echo $f | sed -e 's,/[[^/]]*$,,'`
if test ! -d $d; then
$libgcj_basedir/../mkinstalldirs $d
fi;