aboutsummaryrefslogtreecommitdiff
path: root/libstdc++-v3/testsuite/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libstdc++-v3/testsuite/Makefile.am')
-rw-r--r--libstdc++-v3/testsuite/Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/libstdc++-v3/testsuite/Makefile.am b/libstdc++-v3/testsuite/Makefile.am
index a6a1a78a261..6aecb39485a 100644
--- a/libstdc++-v3/testsuite/Makefile.am
+++ b/libstdc++-v3/testsuite/Makefile.am
@@ -21,8 +21,17 @@
## Software Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307,
## USA.
-AUTOMAKE_OPTIONS = 1.3 cygnus dejagnu
+AUTOMAKE_OPTIONS = foreign dejagnu
-DEJATOOL = libstdc++
+DEJATOOL = libstdc++-v3
+
+EXPECT = `if [ -f @glibcpp_builddir@/../../expect/expect ] ; then \
+ echo @glibcpp_builddir@/../../expect/expect ; \
+ else echo expect ; fi`
+
+RUNTEST = `if [ -f @glibcpp_srcdir@/../dejagnu/runtest ] ; then \
+ echo @glibcpp_srcdir@/../dejagnu/runtest ; \
+ else echo runtest; fi`
+
+RUNTESTFLAGS =
-RUNTEST = runtest