aboutsummaryrefslogtreecommitdiff
path: root/zlib/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'zlib/configure.in')
-rw-r--r--zlib/configure.in39
1 files changed, 22 insertions, 17 deletions
diff --git a/zlib/configure.in b/zlib/configure.in
index 2edccc3b494..16544100174 100644
--- a/zlib/configure.in
+++ b/zlib/configure.in
@@ -1,13 +1,33 @@
dnl Process this with autoconf to create configure
AC_INIT(zlib.h)
+
+dnl We may get other options which we dont document:
+dnl --with-target-subdir, --with-multisrctop, --with-multisubdir
+
+if test "x[$]{with_target_subdir}" != x && \
+ test "[$]{srcdir}" = "."; then
+ if test "[$]{with_target_subdir}" != "."; then
+ zlib_basedir="[$]{srcdir}/[$]{with_multisrctop}../"
+ else
+ zlib_basedir="[$]{srcdir}/[$]{with_multisrctop}"
+ fi
+else
+ zlib_basedir="[$]{srcdir}/"
+fi
+AC_SUBST(zlib_basedir)
+AC_CONFIG_AUX_DIR($zlib_basedir..)
+if :; then :; else
+ # This overrides the previous occurrence for automake, but not for
+ # autoconf, which is exactly what we want.
+ AC_CONFIG_AUX_DIR(..)
+fi
+
AC_CANONICAL_SYSTEM
AM_INIT_AUTOMAKE(zlib, 1.1.3)
AM_MAINTAINER_MODE
-AC_CONFIG_AUX_DIR(..)
-
dnl We use these options to decide which functions to include.
AC_ARG_WITH(target-subdir,
[ --with-target-subdir=SUBDIR
@@ -24,21 +44,6 @@ AC_ARG_ENABLE(multilib,
*) AC_MSG_ERROR(bad value ${enableval} for multilib option) ;;
esac], [test -z "$with_target_subdir" && multilib=no || multilib=yes])dnl
-dnl We may get other options which we dont document:
-dnl --with-target-subdir, --with-multisrctop, --with-multisubdir
-
-if test "x[$]{with_target_subdir}" != x && \
- test "[$]{srcdir}" = "."; then
- if test "[$]{with_target_subdir}" != "."; then
- zlib_basedir="[$]{srcdir}/[$]{with_multisrctop}../"
- else
- zlib_basedir="[$]{srcdir}/[$]{with_multisrctop}"
- fi
-else
- zlib_basedir="[$]{srcdir}/"
-fi
-AC_SUBST(zlib_basedir)
-
AC_ARG_WITH(system-zlib,
[ --with-system-zlib use installed libz])