summaryrefslogtreecommitdiff
path: root/xmlwf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xmlwf/Makefile.am')
-rw-r--r--xmlwf/Makefile.am61
1 files changed, 61 insertions, 0 deletions
diff --git a/xmlwf/Makefile.am b/xmlwf/Makefile.am
new file mode 100644
index 0000000..ff46090
--- /dev/null
+++ b/xmlwf/Makefile.am
@@ -0,0 +1,61 @@
+#
+# __ __ _
+# ___\ \/ /_ __ __ _| |_
+# / _ \\ /| '_ \ / _` | __|
+# | __// \| |_) | (_| | |_
+# \___/_/\_\ .__/ \__,_|\__|
+# |_| XML parser
+#
+# Copyright (c) 2017 Expat development team
+# Licensed under the MIT license:
+#
+# Permission is hereby granted, free of charge, to any person obtaining
+# a copy of this software and associated documentation files (the
+# "Software"), to deal in the Software without restriction, including
+# without limitation the rights to use, copy, modify, merge, publish,
+# distribute, sublicense, and/or sell copies of the Software, and to permit
+# persons to whom the Software is furnished to do so, subject to the
+# following conditions:
+#
+# The above copyright notice and this permission notice shall be included
+# in all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN
+# NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,
+# DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
+# OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE
+# USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+bin_PROGRAMS = xmlwf
+
+xmlwf_LDADD = ../lib/libexpat.la
+xmlwf_SOURCES = \
+ xmlwf.c \
+ xmlfile.c \
+ codepage.c \
+ @FILEMAP@.c
+
+xmlwf_CPPFLAGS = -I$(srcdir)/../lib
+
+if MINGW
+if UNICODE
+xmlwf_CPPFLAGS += -mwindows
+xmlwf_LDFLAGS = -municode
+endif
+endif
+
+EXTRA_DIST = \
+ codepage.h \
+ ct.c \
+ filemap.h \
+ readfilemap.c \
+ unixfilemap.c \
+ win32filemap.c \
+ xmlfile.h \
+ xmlmime.c \
+ xmlmime.h \
+ xmltchar.h \
+ xmlurl.h \
+ xmlwin32url.cxx