summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGert Wollny <gw.fossdev@gmail.com>2017-10-18 17:05:26 +0200
committerEmil Velikov <emil.l.velikov@gmail.com>2017-11-08 16:03:38 +0000
commit8f18528ceade31168be76edbb9fb2c09760fad21 (patch)
tree28593803c8d64c741626413ba7c0449a8d511848 /configure.ac
parent09ad2576ece2f813e5be9dda60fdb0b9598d0d23 (diff)
swr: Replace the check for c++11 by the unified version
Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 14236c9dc9..3dd9b9a4ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2582,10 +2582,9 @@ if test -n "$with_gallium_drivers"; then
xswr)
llvm_require_version $LLVM_REQUIRED_SWR "swr"
- swr_require_cxx_feature_flags "C++11" "__cplusplus >= 201103L" \
- ",-std=c++11" \
- SWR_CXX11_CXXFLAGS
- AC_SUBST([SWR_CXX11_CXXFLAGS])
+ if test "x$HAVE_CXX11" != "xyes"; then
+ AC_MSG_ERROR([swr requires c++11 support])
+ fi
swr_require_cxx_feature_flags "AVX" "defined(__AVX__)" \
",-target-cpu=sandybridge,-mavx,-march=core-avx,-tp=sandybridge" \