aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKrisztian Litkey <krisztian.litkey@nokia.com>2010-10-25 13:02:20 +0300
committerKrisztian Litkey <krisztian.litkey@nokia.com>2010-10-25 13:02:20 +0300
commitf75d4a3527f47505333989d08683837a8ecc9110 (patch)
tree38459338584fc55737c270ebfe7df2525bb58c19 /configure.ac
parent35a5764e969ce85adb761357056fe729c699f8a5 (diff)
Use shave for Kbuild-like compilation verbosity control.v0.18.0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 15 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 87f1638..100a8fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,11 +7,14 @@ AC_INIT([libresource],
[multimedia at ok.research.nokia.com])
AC_CONFIG_SRCDIR([src])
+AC_CONFIG_MACRO_DIR([m4])
#AC_CONFIG_AUX_DIR([build-aux])
AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
AC_CONFIG_HEADERS([config.h])
+AC_SUBST(ACLOCAL_AMFLAGS, "-I m4")
+
AC_PROG_CC
AC_PROG_GCC_TRADITIONAL
AC_GNU_SOURCE
@@ -54,14 +57,18 @@ AS_HELP_STRING([--enable-debug],[Enable debug (log) @<:@default=false@:>@]),
esac],[debug=false])
AM_CONDITIONAL([DEBUG], [test x$debug = xtrue])
-
-AC_CONFIG_FILES([libresource0.pc
- libresource0-glib.pc
- Makefile
- src/Makefile
- client/Makefile
- examples/Makefile
- tests/Makefile
+# shave
+SHAVE_INIT([build-aux], [enable])
+
+AC_CONFIG_FILES([build-aux/shave
+ build-aux/shave-libtool
+ libresource0.pc
+ libresource0-glib.pc
+ Makefile
+ src/Makefile
+ client/Makefile
+ examples/Makefile
+ tests/Makefile
])
AC_OUTPUT