aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGergely Risko <gergely+context@risko.hu>2009-11-17 14:33:01 +0200
committerGergely Risko <gergely+context@risko.hu>2009-11-17 14:33:01 +0200
commit2472d86f33825d2d6ead07524bff6389e4c39ad2 (patch)
tree42e09ac2c2a5dc246ae037444d48ace268c05a98 /configure.ac
parent2358aa484093a0aded4b656fd2c560bfab40ef6f (diff)
make dist fixes
create context{provider,subscriber}-1.0-uninstalled.pc from ...pc.in at configure time create the libcontextprovider/src/context -> . symlink at configure time removed the symlink from the git repo libcontextprovider/customer-tests: distribute env.sh and types/types.py
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b33834e9..0d9110d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,6 +29,8 @@ AC_PROG_QT_RCC
AC_CHECK_LIB([cdb], [cdb_make_start], [CDB_LIBS=-lcdb], [AC_MSG_ERROR([Can't find cdb library])])
AC_SUBST([CDB_LIBS])
+AC_PROG_LN_S
+
# tools for documentation
AX_FEATURE_DISABLEABLE([doc], [BUILD_DOCS], [disable building of documentation])
AX_DISABLE_FEATURE_ON_PROG([Dot drawing tool], [BUILD_DOCS], [DOT], [dot])
@@ -53,6 +55,7 @@ AC_CONFIG_FILES([
libcontextsubscriber/cli/Makefile
libcontextsubscriber/cls/Makefile
libcontextsubscriber/contextsubscriber-1.0.pc
+ libcontextsubscriber/contextsubscriber-1.0-uninstalled.pc
libcontextsubscriber/customer-tests/Makefile
libcontextsubscriber/customer-tests/update-contextkit-providers/Makefile
libcontextsubscriber/customer-tests/testplugins/Makefile
@@ -79,6 +82,7 @@ AC_CONFIG_FILES([
libcontextsubscriber/update-contextkit-providers/Makefile
libcontextsubscriber/propertymonitor/Makefile
libcontextprovider/contextprovider-1.0.pc
+ libcontextprovider/contextprovider-1.0-uninstalled.pc
libcontextprovider/Makefile
libcontextprovider/doc/Makefile
libcontextprovider/src/Makefile
@@ -110,3 +114,5 @@ AX_FEATURE_SUMMARIZE([BUILD_DOCS],
AX_FEATURE_SUMMARIZE([COVERAGE],
[Unit testing coverage support is enabled],
[Coverage won't be supported during unit testing])
+
+$LN_S . libcontextprovider/src/context